[quagga-dev 269] multitable in zebra 0.94-pre5 (fwd)

Krzysztof Olędzki ole at ans.pl
Mon Sep 29 09:23:31 BST 2003


Hello,

OK, since the same problem exists in Quagga 0.96.2 I decided to send
this bug report also to this list. Espacially, that I'm not a member of
zebra at zebra.org and my mail has to be verified by moderator which takes
much time. ;-)


---------- Forwarded message ----------
Date: Tue, 23 Sep 2003 15:22:33 +0200 (CEST)
From: Krzysztof Olędzki <ole at ans.pl>
To: zebra at zebra.org, Kunihiro Ishiguro <kunihiro at ipinfusion.com>
Subject: multitable in zebra 0.94-pre5

Hello.

It seems there is something wrong with multitable support in zebra
0.94-pre5 and Linux 2.4.x.

I have Linux router with 3 links - 2 to one ISP (lets call this
ISP0) one one to other one (ISP1). I exchange RIP2 routing with ISP0
so when one of the links goes down my router immediately switches
default routing to other link. Since both ISPs do source validation
I decided to use source routing. Let's assume that 192.168.0.0/24
belongs to ISP0 and 192.168.1.0/24 belongs to ISP1. My configuration
looks something like this:

rule add from 192.168.1.0/24 table 5
ip route add 0/0 dev isp1 table 5

Default routing for default table is set up by zebra&ripd.

Unfortunately, zebra refuses to install default route (or
any other route) if it detects that this route exist and
is set by kernel. I think that it should check if existed
route is in current table and if not process route insertion.


It also seems that there is something wrong with "table" command.
With following zebra.conf file:
----------
hostname zebra
password zebra

table 5
 ip route 0.0.0.0/0 192.168.0.240
----------

zebra inserts "0.0.0.0/0 via 192.168.0.240" route to default
table. According to manual zebra should install static routes to table 5!
Anyway, "show ip route" shows empty routing table until I started ripd -
then it shows RIP routes marked as "inactive" which are not inserted to
any kernel table. Strange - manual (main.texi) says that only static
routes defined after this command go to the specified table.

Zebra was build with:
./configure --prefix=/usr --sysconfdir=/etc/zebra \
    --enable-netlink --enable-multipath=0 --enable-tcp-zebra \
    --enable-vtysh --enable-snmp

Tested on kernels 2.4.21, 2.4.23-pre4.

Best Regards,


					Krzysztof Olędzki






More information about the Quagga-dev mailing list