[quagga-dev 1432] Re: questions

Li, Qing qing.li at bluecoat.com
Mon Aug 23 22:26:49 BST 2004


My system is FreeBSD 5.2.1-RELEASE. I did reinstall autoconf and did not
fix my problem.

I'm getting the following errors during configure, then during
compilation with the 
snapshot tarball.

-----------------

configure: WARNING: netinet6/nd6.h: present but cannot be compiled
configure: WARNING: netinet6/nd6.h:     check for missing prerequisite
headers?
configure: WARNING: netinet6/nd6.h: see the Autoconf documentation
configure: WARNING: netinet6/nd6.h:     section "Present But Cannot Be
Compiled"
configure: WARNING: netinet6/nd6.h: proceeding with the preprocessor's
result
configure: WARNING: netinet6/nd6.h: in the future, the compiler will
take precedence
configure: WARNING:     ## ----------------------------------------- ##
configure: WARNING:     ## Report this to http://bugzilla.quagga.net ##
configure: WARNING:     ## ----------------------------------------- ##

The same type of errors are there for net/route.h, net/if.h,
net/if_var.h,
netinet/in_var.h, netinet/icmp6.h, netinet/in6_var.h

/bin/sh ../libtool --mode=link gcc  -g -O2 -O    -o ospfd  ospf_main.o
libospf.la ../lib/lib
zebra.la -lm -lcrypt -L/usr/local/v6/lib -linet6
gcc -g -O2 -O -o .libs/ospfd ospf_main.o  ./.libs/libospf.so
-L/usr/local/v6/lib ../lib/.lib
s/libzebra.so -lm -lcrypt -linet6 -Wl,--rpath -Wl,/usr/local/lib
./.libs/libospf.so: undefined reference to `SOPT_SIZE_CMSG_PKTINFO_IPV4'
*** Error code 1

Stop in /usr/local/src/quagga-0.96.5/ospfd.
*** Error code 1

Stop in /usr/local/src/quagga-0.96.5.
*** Error code 1

Stop in /usr/local/src/quagga-0.96.5.

> 




More information about the Quagga-dev mailing list