[quagga-dev 1326] Re: libtool support about to be added

Greg Troxel gdt at ir.bbn.com
Thu Jul 1 13:40:24 BST 2004


  [re libospf]

  OSPF-API needs it. So it needs to be installed if one wishes to link
  OSPF-API using applications. For the RPMs, it's only installed with
  the quagga-devel package.

I'm not an RPM expert, but:

It would seem that the .so versions of the libraries belong in the
base package (since a program linked with them will need it).  The .a
versions and the include files belong in the -devel package.

One could also split the apiclient stuff into
quagga-ospfclient{,-devel}, but that would only save about 250k, and
it doesn't seem worth it.

-- 
        Greg Troxel <gdt at ir.bbn.com>



More information about the Quagga-dev mailing list