[quagga-dev 4570] ospfd assertion `new_distance <= w->distance' failed

Anders K. Pedersen mailnews+router-quagga-dev at news.cohaesio.com
Sun Feb 4 18:46:20 GMT 2007


Hello,

I have configured a new test router (r3-test) with quagga-devel from CVS
as of January 27th (the later changes doesn't have any influence on
ospfd, as far as I can tell).

The zebra daemon is running without any problems, but when starting
ospfd it consistently crashes after a few seconds with the following
stack trace:

2007/02/04 18:55:45 OSPF: Assertion `new_distance <= w->distance' failed
in file ospf_spf.c, line 442, function ospf_spf_add_parent
2007/02/04 18:55:45 OSPF: Backtrace for 11 stack frames:
2007/02/04 18:55:45 OSPF: [bt 0]
/usr/lib/libzebra.so.0(zlog_backtrace+0x1f) [0xb7f2cfe0]
2007/02/04 18:55:45 OSPF: [bt 1]
/usr/lib/libzebra.so.0(_zlog_assert_failed+0x83) [0xb7f2d200]
2007/02/04 18:55:45 OSPF: [bt 2] /usr/lib/libospf.so.0 [0xb7f7b9d5]
2007/02/04 18:55:45 OSPF: [bt 3] /usr/lib/libospf.so.0 [0xb7f7bd73]
2007/02/04 18:55:45 OSPF: [bt 4] /usr/lib/libospf.so.0 [0xb7f7c07c]
2007/02/04 18:55:45 OSPF: [bt 5] /usr/lib/libospf.so.0 [0xb7f7c6d4]
2007/02/04 18:55:45 OSPF: [bt 6] /usr/lib/libospf.so.0 [0xb7f7c825]
2007/02/04 18:55:45 OSPF: [bt 7]
/usr/lib/libzebra.so.0(thread_call+0x62) [0xb7f2281b]
2007/02/04 18:55:45 OSPF: [bt 8] /usr/lib/quagga/ospfd(main+0x28f)
[0x80493f0]
2007/02/04 18:55:45 OSPF: [bt 9]
/lib/tls/libc.so.6(__libc_start_main+0xf4) [0xb7d97974]
2007/02/04 18:55:45 OSPF: [bt 10] /usr/lib/quagga/ospfd [0x8049051]

ospfd.conf and ospfd.log are attached (with passwords and IPs changed).
A quick overview over the network layout follows:

There are 2 network segments connected to this router running OSPF:
10.0.1.0/24 and 10.0.4.0/22. 10.0.0.0/24 is used /32 loop-back addresses
on dummy interfaces.

There are two main routers (r2 and r4), the test router that crashed
above (r3-test), and some other routers that interface with other segments.

r2 has IPs 10.0.0.2/32, 10.0.1.2/24, and 10.0.4.2/22.
r4 has IPs 10.0.0.4/32, 10.0.1.4/24, and 10.0.4.4/22.
r3-test has IPs 10.0.0.3/32, 10.0.1.3/24, and 10.0.4.3/22.

r3-test is running Debian Sarge Linux.

Let me know if any further information is needed - I am willing to try
patches etc., and like I said, the crash happens consistently within
seconds after starting ospfd.

Regards,
Anders K. Pedersen
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: ospfd.conf
URL: <http://lists.quagga.net/pipermail/quagga-dev/attachments/20070204/88f7400b/attachment-0002.ksh>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: ospfd.log
URL: <http://lists.quagga.net/pipermail/quagga-dev/attachments/20070204/88f7400b/attachment-0003.ksh>


More information about the Quagga-dev mailing list