[quagga-dev 5297] Re: RIP failed to send periodic update

Bhartendu Maheshwari Bhartendu.Maheshwari at conexant.com
Thu Apr 10 06:00:22 BST 2008


Hello Andrew,

Thanks for the response. I have checked - Interfaces are properly shown in zebra list, NO interface shown in rip interface list.

As per your observation I am sure that there might be some problem in communication b/w zebra and ripd. Please advice me how I can debug it.
What all steps I should do or check to correct this problem.

Please let me know if you need any further information.

Thanks & Regards
Bhartendu M.

==============
RIP logs
==============

bharat# show ip rip status
Routing Protocol is "rip"
  Sending updates every 30 seconds with +/-50%, next due in 27 seconds
  Timeout after 180 seconds, garbage collect after 120 seconds
  Outgoing update filter list for all interface is not set
  Incoming update filter list for all interface is not set
  Default redistribution metric is 1
  Redistributing:
  Default version control: send version 2, receive any version
    Interface        Send  Recv   Key-chain
  Routing for Networks:
    192.168.1.0/24
  Routing Information Sources:
    Gateway          BadPackets BadRoutes  Distance Last Update
  Distance: (default is 120)
bharat#

=============
Zebra Logs
=============
bharat# show interface
  [IFNAME]     Inteface name
  description  Interface description
bharat# show interface
Interface eth0 is up, line protocol detection is disabled
  index 3 metric 1 mtu 1500
  flags: <UP,BROADCAST,RUNNING,MULTICAST>
  HWaddr: 00:19:5b:6c:53:42
  inet 192.168.1.2/24 broadcast 192.168.1.255
  inet6 fe80::219:5bff:fe6c:5342/64
    57787 input packets (0 multicast), 5324166 bytes, 0 dropped
    0 input errors, 0 length, 0 overrun, 0 CRC, 0 frame
    0 fifo, 0 missed
    1282 output packets, 62559 bytes, 0 dropped
    0 output errors, 0 aborted, 0 carrier, 0 fifo, 0 heartbeat
    0 window, 0 collisions
Interface eth1 is up, line protocol detection is disabled
  index 2 metric 1 mtu 1500
  flags: <UP,BROADCAST,MULTICAST>
  HWaddr: 00:18:8b:10:18:bc
  inet 10.0.0.2/8 broadcast 10.255.255.255
    0 input packets (0 multicast), 0 bytes, 0 dropped
    0 input errors, 0 length, 0 overrun, 0 CRC, 0 frame
    0 fifo, 0 missed
    0 output packets, 0 bytes, 0 dropped
    0 output errors, 0 aborted, 0 carrier, 0 fifo, 0 heartbeat
    0 window, 0 collisions
Interface lo is up, line protocol detection is disabled
  index 1 metric 1 mtu 16436
  flags: <UP,LOOPBACK,RUNNING>
  inet 127.0.0.1/8
  inet6 ::1/128
    2531 input packets (0 multicast), 3603068 bytes, 0 dropped
    0 input errors, 0 length, 0 overrun, 0 CRC, 0 frame
    0 fifo, 0 missed
    2531 output packets, 3603068 bytes, 0 dropped
    0 output errors, 0 aborted, 0 carrier, 0 fifo, 0 heartbeat
    0 window, 0 collisions
Interface tmpbridge is down
  index 5 metric 1 mtu 1500
  flags: <BROADCAST,MULTICAST>
    0 input packets (0 multicast), 0 bytes, 0 dropped
    0 input errors, 0 length, 0 overrun, 0 CRC, 0 frame
    0 fifo, 0 missed
    0 output packets, 0 bytes, 0 dropped
    0 output errors, 0 aborted, 0 carrier, 0 fifo, 0 heartbeat
    0 window, 0 collisions
Interface virbr0 is up, line protocol detection is disabled
  index 4 metric 1 mtu 1500
  flags: <UP,BROADCAST,RUNNING,MULTICAST>
  inet 192.168.122.1/24 broadcast 192.168.122.255
  inet6 fe80::200:ff:fe00:0/64
    0 input packets (0 multicast), 0 bytes, 0 dropped
    0 input errors, 0 length, 0 overrun, 0 CRC, 0 frame
    0 fifo, 0 missed
    34 output packets, 5287 bytes, 0 dropped
    0 output errors, 0 aborted, 0 carrier, 0 fifo, 0 heartbeat
    0 window, 0 collisions
bharat#


-----Original Message-----
From: Andrew J. Schorr [mailto:aschorr at telemetry-investments.com]
Sent: Wednesday, April 09, 2008 8:15 PM
To: Bhartendu Maheshwari
Cc: quagga-dev at lists.quagga.net
Subject: Re: [quagga-dev 5295] RIP failed to send periodic update

Hi,

On Wed, Apr 09, 2008 at 11:03:54AM +0530, Bhartendu Maheshwari wrote:
> I have installed quagga-0.99.6 on linux fedora code 8. My machine has two ethernet cards.
>
> Problem : I have started zebra and then ripd but rip is not sending any routes on the interfaces.
> I have analysis and found that in function "rip_update_process" the global variable "iflist" has no element.
> That is the reason its not sending update to any interfaces.

Is it clear that ripd and zebra are communicating successfully?

> I have attached my rip logs, ripd.conf and zebra.conf. Please let me know if this is configuration issue or
> machine issue. I have tried this with two machine but same behavior.

What is the output of zebra "show interface" and
ripd "show ip rip status"?

Regards,
Andy

Conexant E-mail Firewall (Conexant.Com) made the following annotations
---------------------------------------------------------------------
********************** Legal Disclaimer **************************** 

"This email may contain confidential and privileged material for the sole use of the intended recipient. Any unauthorized review, use or distribution by others is strictly prohibited. If you have received the message in error, please advise the sender by reply email and delete the message. Thank you." 

********************************************************************** 

---------------------------------------------------------------------





More information about the Quagga-dev mailing list