[quagga-dev 5306] intermittent communication between bgpd and zebra?

Ray Barnes rrb at colo4jax.com
Fri Apr 18 06:32:54 BST 2008


 Hi all.  I'm having issues making bgpd forcefully communicate with zebra
(or is it the other way around?).  This happens with the version of quagga
shipping with CentOS 5.1, as well as 0.99.9.  I've setup one of my core
routers to send default routes to a server over separate paths for failover
purposes.  The defaults are being sent just fine; bgpd shows them coming
from both peer addresses.  The problem I'm having is that if I start bgpd
before zebra, those routes will never get propagated into zebra if they
don't change.  If I go into bgpd and "clear bgp *" it will reset the bgp
sessions and receive routes again, at which point the default gets installed
to zebra and into the kernel.  But otherwise, never anything in zebra.  It's
apparent to me that bgpd/zebra never try actively talking to each other to
synchronize; why?

-Ray

! bgpd.conf, IPs have been changed to protect the innocent
hostname bgpd
password xxx
enable password xxx
log stdout
!
router bgp 65000
 bgp router-id 4.106.107.66
 bgp scan-time 5
 network 4.106.107.66/32
 network 4.106.107.88/29
 timers bgp 1 3
 neighbor 4.103.144.17 remote-as 12345
 neighbor 4.103.144.17 advertisement-interval 2
 neighbor 4.103.144.129 remote-as 12345
 neighbor 4.103.144.129 advertisement-interval 2
!
ip prefix-list DENYALL seq 5 deny any
!
line vty


!zebra.conf
hostname yea
password xxx
enable password xxx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-dev/attachments/20080418/e97bfffb/attachment-0001.html>


More information about the Quagga-dev mailing list