[quagga-dev 6293] Re: rip version 1 bug?

Lennart Sorensen lsorense at csclub.uwaterloo.ca
Thu Dec 18 19:18:55 GMT 2008


On Wed, Dec 17, 2008 at 05:50:27PM -0600, Laverdiere,Phil wrote:
> I have a customer who found a problem with rip version 1.  I know, they
> should be using rip version 2, but for some bizarre reason they want to use
> version 1.
> 
> Anyway, what happens is that ripd only advertises interface routes if the
> address is on the same classfull network.

That would be because RIPv1 by spec only works with classfull networks.
RIPv1 has no concept of netmask's in the protocol because they didn't
exist at the time.  That is why we have RIP v2 is to make RIP work with
netmasks rather than classfull networks.

So RIPv1 explicitly means classfull networks only.

RIPv2 means use netmasks.

So if the customer wants RIPv1, then they must also want classfull
networks only on their network.

-- 
Len Sorensen



More information about the Quagga-dev mailing list