[quagga-dev 8349] Problem with 2 AS Peers as multiple-instance

Ref. EDV im KSV Uelzen edv at ksv-uelzen.de
Thu Nov 11 00:37:33 GMT 2010


 Hy folks

 I have the following Quagga setup, which represents 2 instances with
 different peers.

 ! -*- bgp -*-
 !
 log file /opt/quagga/var/log/bgpd.log
 debug bgp
 !
 hostname db0fhw
 password
 service advanced-vty
 !
 bgp multiple-instance
 !
 !
 ! DB0ABZ
 router bgp 65530
  bgp router-id 44.225.64.154
  bgp confederation identifier 64636
  bgp confederation peers 65526 65527 65528 65529
  network 44.225.66.128/26
  neighbor 44.225.64.130 remote-as 65527
  neighbor 44.225.64.130 prefix-list pref-accept-in in
  neighbor 44.225.64.130 prefix-list pref-filter-out out
  neighbor 44.225.64.131 remote-as 65526
  neighbor 44.225.64.131 prefix-list pref-accept-in in
  neighbor 44.225.64.131 prefix-list pref-filter-out out
  neighbor 44.225.64.132 remote-as 65528
  neighbor 44.225.64.132 prefix-list pref-accept-in in
  neighbor 44.225.64.132 prefix-list pref-filter-out out
  neighbor 44.225.64.133 remote-as 65529
  neighbor 44.225.64.133 prefix-list pref-accept-in in
  neighbor 44.225.64.133 prefix-list pref-filter-out out
 !
 !
 ! DB0FHN
 router bgp 64636
  bgp router-id 44.224.12.234
  neighbor 44.224.12.233 remote-as 64626
  neighbor 44.224.12.233 prefix-list pref-accept-in in
  neighbor 44.224.12.233 prefix-list pref-deny-out out
 !
 !
 !
 ip prefix-list pref-accept-in permit any
 !
 ip prefix-list pref-filter-out permit 44.225.64.128/25
 ip prefix-list pref-filter-out permit 44.225.66.128/26
 ip prefix-list pref-filter-out deny any
 !
 ip prefix-list pref-deny-out deny any
 !
 !
 !
 access-list localhost-in permit 127.0.0.1/32
 !
 line vty
  access-class localhost-in
 !
 !


 But I allways get the error message: BGP view name and AS number mismatch

 But the BGP Confederation should "identify" itself as 64636 (wich ist my
 AS) und the external AS ist 64626

 my AS 64636 is internally split into a confederation because you do not
 need to set up more peers to each router, if a new router comes into the
 iBGP world.

 What is wrong with the config file and/or how do I best connect the eBPG
 AS 64626 ??

 Greetings
 Micha



More information about the Quagga-dev mailing list