[quagga-dev 8471] Re: [quagga-users 12034] ospfd nssa issue

Han Coumans hjcoumans at gmail.com
Wed Jan 5 07:47:28 GMT 2011


Dear "Wu, Yiwen" and Quagga users/devs,


This is not a final email concerning the issue as I continue to investigate.

I can confirm OP's behavior, but must also add it is intermittent and until
now I'm not able to reproduce the issue consistently.

Often, but not always the erroneous behavior shows at cold boot of the ABR,
sometimes also on the restart of zebra and ospfd (with a 40 second delay
between daemon kill and start). Until now, the issue never showed itself
during ospfd restart (with or without a 40 second sleep in between).

Roughly 60 tests were done until now.
  Breakdown:
    A few tests on the ABR with zebra and ospfd killed, 40 second sleep and
zebra started, 1 second sleep and ospfd started. The reported issue did
occur at least once.
    Around 10 tests on the ABR to kill zebra and ospfd, wait 40 second and
reboot the machine. Plm 40% of the time the issue showed.
    Around 10 tests on the ABR to kill zebra and ospfd, wait 40 seconds and
restart zebra and ospfd immediately after each other. Also a plm 40% the
issue showed.
    Around 10 tests on the ABR having the connected routers running and cold
boot the ABR. Again plm 40% score
    Around 15 tests on the ABR restarting the ospf daemon without sleep
time. Never got the issue.
    Remaining test on the ASBR or the router between the ASBR and the ABR
stopping ospfd with and without sleep time and also reboots. No statistics.

The interfaces get their IP address from zebra. I will test if it makes a
difference if Linux does the IP setting and will report back to you.


Test environment:

All machines:
# uname -a
Linux ...... 2.6.18-128.1.10.el5.xs5.5.0. 51xen #1 SMP Fri May 29 06:29:19
EDT 2009 i686 athlon i386 GNU/Linux
aka Centos 5 x86 on Citrix Xenserver 5.6.0.

ASBR (nssa), ABR, router in between (nssa):
Quagga-0.99.17 (release)

Directly connected (area 0) router to ABR:
Quagga-0.99.8 (release)

All hello and dead timers for these routers are default.


Regards and cheers,

Han

Date: Tue, 28 Dec 2010 11:42:01 -0500
From: "Wu, Yiwen" <ywu at idirect.net>
To: <quagga-users at lists.quagga.net
>
Subject: [quagga-users 12034] ospfd nssa issue
Message-ID:
       <C874DBE9D30B584587F8CD0EC34DA8BE1A27DC19 at EX00.idirect.net>
Content-Type: text/plain; charset="us-ascii"

Hi all,

I got great trouble to make ospfd NSSA working. Router R6 injects two
extern routes 10.0.0.0/24 and 10.0.0.1/24 and R5 redistributes these two
routes to OSPF. I am seeing a few strange thing:

1. when doing "sh ip ospf border-router" on R2~R5, it shows that R1 is
ASBR and ABR. It didn't happen when using the same topology but no NSSA.

2. The two external routes didn't appear in R2's RIB. I turned on debug
in R1 and found the following word in the ospfd.log file for each Type 7
message R1 receives.

"OSPF: Route[External]: Can't find originating ASBR route"

Does anyone see the similar thing before?

Thanks,


Here is my network topology


++++     ++++   area 0.0.0.0   ++++
+R4+++++++R1++++++++++++++++++++R2+
++++  +  ++++                  ++++
     +
area 0.0.0.1
     +
    ++++
    +R5+
    ++++
     +
     + (external RIP)
    ++++
    +R6+
    ++++

R1 Config:
router-id 192.0.0.1
network 192.168.10.0/24 area 0.0.0.0
network 192.168.20.0/24 area 0.0.0.1
area 0.0.0.1 nssa translate-candidate

R2 config:
router-id 192.0.0.2
network 192.168.10.0/24 area 0.0.0.0

R4 config:
router-id 192.0.0.4
network 192.168.20.0/24 area 0.0.0.1
area 0.0.0.1 nssa translate-candidate

R5 Config:
router ospf
 ospf router-id 192.0.0.5
 network 192.168.20.0/24 area 0.0.0.1
 redistribute rip
 redistribute connected
 area 0.0.0.1 nssa translate-candidate
!
router rip
 version 2
 network 192.168.40.0/24

R6 Config:
router rip
 version 2
 network 192.168.40.0/24


</PRE><BR><span
style='font-size:8.0pt;font-family:"Arial","sans-serif";color:#003366'>
_____________________________________________________<BR>
This electronic message and any files transmitted with it contains<BR>
information from iDirect, which may be privileged, proprietary<BR>
and/or confidential. It is intended solely for the use of the individual<BR>
or entity to whom they are addressed. If you are not the original<BR>
recipient or the person responsible for delivering the email to the<BR>
intended recipient, be advised that you have received this email<BR>
in error, and that any use, dissemination, forwarding, printing, or<BR>
copying of this email is strictly prohibited. If you received this email<BR>
in error, please delete it and immediately notify the sender.<BR>
_____________________________________________________
</SPAN><PRE>



------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-dev/attachments/20110105/c6305654/attachment-0001.html>


More information about the Quagga-dev mailing list