[quagga-dev 8720] Re: ospfd+freebsd 8.2

Vitaly Liaschuk larinus at gmail.com
Wed May 4 11:32:13 BST 2011


Sorry, guys it was my fault. I  used wrong netmask on interface and
in ospfd.conf

On Wed, 4 May 2011 12:56:19 +0300
Vitaly Liaschuk <larinus at gmail.com> wrote:

> Hi, list!
> 	I'm trying to configure ospfd on my freebsd server. Here is my
> 	config:
> BRAS10# sh run
> Building configuration...
> 
> Current configuration:
> !
> hostname zebra
> log file /usr/local/etc/quagga/zebra.log
> hostname bras10
> log file /usr/local/etc/quagga/ospfd.log
> !
> password 123
> enable password 123
> !
> interface em0
>  ip ospf cost 65
>  ip ospf dead-interval 8
>  ip ospf hello-interval 2
>  link-detect
>  multicast
>  no ipv6 nd suppress-ra
> !
> interface ipfw0
>  ipv6 nd suppress-ra
> !
> interface lo0
> !
> interface re0
>  ipv6 nd suppress-ra
> !
> router ospf
>  ospf router-id 172.22.1.10
>  redistribute connected
>  passive-interface default
>  no passive-interface em0
>  network 172.22.1.0/24 area 0.0.0.0
>  neighbor 172.22.1.5
> !
> ip route 0.0.0.0/0 212.98.173.1
> ip route 10.0.0.0/8 Null0 254
> ip route 172.16.0.0/12 Null0 254
> ip route 192.168.0.0/16 Null0 254
> !
> ip forwarding
> !
> line vty
> !
> end
> 
> In my configuration I turned on ospf on em0 interface. In google I
> found assumption what it's could occure because  zebrad do not gives
> active interfaces to the ospfd. 
> 
> NAS10# ls -la /var/run/quagga/
> total 8
> drwxrwxrwx  2 quagga  quagga  512 May  4 12:21 .
> drwxr-xr-x  6 root    wheel   512 May  4 12:21 ..
> -rw-r--r--  1 quagga  quagga    4 May  4 12:21 ospfd.pid
> srwxrwx---  1 quagga  quagga    0 May  4 12:21 ospfd.vty
> -rw-r--r--  1 quagga  quagga    4 May  4 12:21 zebra.pid
> srwxrwx---  1 quagga  quagga    0 May  4 12:21 zebra.vty
> srwx------  1 quagga  quagga    0 May  4 12:21 zserv.api
> 
> I tried recompile quagga with option WITH_TCPSOCKETS, but it did not
> help:
> 
> NAS10# sh ip o i em0
> em0 is up
>   ifindex 1, MTU 1500 bytes, BW 0 Kbit
> <UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> OSPF not enabled on this
> interface NAS10# 
> 
> 
> So, maybe it is a freebsd specific  bug? Can anyone confirm this?



More information about the Quagga-dev mailing list