[quagga-dev 8727] Serious problem with community value

Huq A. 1 a.m.huq at aalto.fi
Fri May 27 18:11:21 BST 2011


Guys,
I have a serious problem with community attribute. I have 2 machines. Machine 2 has a C program that runs in a loop and sends two BGP update messages to Machine 1 separately. In other words, Machine 1 gets two community values over time. The C program uses “vtysh -c” to put the commands into Quagga. Now, the result of “sh running-config” in Machine 2 looks like:

Building configuration...



Current configuration:

!

hostname Router

hostname bgpd

log stdout

!

password zebra

enable password zebra

!

interface eth0

 ipv6 nd suppress-ra

!

interface eth1

 ipv6 nd suppress-ra

!

interface eth2

 ipv6 nd suppress-ra

!

interface eth3

 ipv6 nd suppress-ra

!

interface lo

!

router bgp 100

 bgp router-id 192.168.56.101

 network 10.10.30.1/32

 network 192.168.57.0/24

 timers bgp 0 0

 neighbor 10.144.13.55 remote-as 7675

 neighbor 10.144.13.55 route-map OUTBOUND out

 neighbor 10.144.13.65 remote-as 7675

!

ip prefix-list PLIST1 seq 5 permit 0.0.0.0/0 le 32

!

route-map OUTBOUND permit 10

 match ip address prefix-list PLIST1

 set community 2420:0

!

ip forwarding

!

line vty

Now, as I have said, the C program sends two community values to machine 1. In machine 1, I get:



xTR# sh ip bgp community-info

Address Refcnt Community

[0x22112770] (1) 2420:0

[0x22112780] (1) 2274:0



What I need is to get only the latest value. i.e. I only want to see 2420:0. What can I do in machine 1 so that only the latest community value is seen? I did not use any “additive” keyword while sending the community attribute.



Also what’s the large Hexa number to the left of the community value? And what does “(1)” mean?



Please help.


Bye.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-dev/attachments/20110527/853e36b2/attachment-0001.html>


More information about the Quagga-dev mailing list