[quagga-dev 8874] Re: Quagga 0.99.19 security patch causes ospfd crash

Denis Ovsienko infrastation at yandex.ru
Wed Sep 28 18:07:29 BST 2011


28.09.2011, 05:03, "YAMAMOTO Shigeru" <shigeru at iij.ad.jp>:
> Hi all,
>
> ospfd in our environment is crashed after 0.99.19.
>
> It is caused by 'ospfd: CVE-2011-3325 part 2 (OSPF pkt type segv)' patch.
> # It is already reported by Denis Ovsienko.

Logic-wise this change looks to fix the error, which was introduced by my fix to the CVE. Does it resolve the crash on your side completely? It has never reproduced in my environment, so I need some feedback before proceeding with a correcting release.

-- 
    Denis Ovsienko



More information about the Quagga-dev mailing list