[quagga-dev 16570] OSPF route cannot be established

詹益晨 yicchan90 at gmail.com
Tue Feb 14 10:09:36 GMT 2017


Hell everyone,
There is a gre network with ospf.
I use Quagga ospfd connect with other OSPF equipment, but the route cannot
learn from peer OSPF equipment.
This is ospf database log, does anyone know if the Link ID 0.0.0.0 is the
reason causes route cannot be established?
===========================================================
530> show ip ospf database

       OSPF Router with ID (172.16.2.254)

                Router Link States (Area 0.0.0.0)

Link ID         ADV Router      Age  Seq#       CkSum  Link count
172.16.1.248    172.16.1.248     441 0x80000e27 0x9e87 3
172.16.1.249    172.16.1.249    1312 0x80000de9 0x1a64 1
172.16.2.254    172.16.2.254     436 0x80000008 0x9271 4

                Net Link States (Area 0.0.0.0)

Link ID         ADV Router      Age  Seq#       CkSum
26.26.26.1      172.16.1.248     440 0x80000001 0x904f
172.16.1.249    172.16.1.249     411 0x80000dbf 0xefc0

                AS External Link States

Link ID         ADV Router      Age  Seq#       CkSum  Route
*0.0.0.0         172.16.1.248     345 0x80000dcc 0xdc67 E2 0.0.0.0/0
<http://0.0.0.0/0> [0x0]*
*0.0.0.0         172.16.1.249    1242 0x80000dc3 0xe863 E2 0.0.0.0/0
<http://0.0.0.0/0> [0x0]*
10.10.101.0     172.16.1.248    1425 0x800008f7 0x3f65 E2 10.10.101.0/24
 [0x0]
10.10.101.1     172.16.2.254     436 0x80000006 0xf60c E2 10.10.101.1/32
 [0x0]
10.10.104.0     172.16.1.248     705 0x8000071b 0xdaa4 E2 10.10.104.0/24
 [0x0]
10.10.112.0     172.16.1.248    1425 0x800008f7 0xc5d3 E2 10.10.112.0/24
 [0x0]
10.20.30.0      172.16.1.248     345 0x8000014f 0x3d54 E2 10.20.30.0/24
 [0x0]
172.16.0.0      172.16.1.248     525 0x80000dc4 0x6728 E2 172.16.0.0/24
 [0x0]
172.16.0.0      172.16.1.249    1242 0x80000dc3 0x632c E2 172.16.0.0/24
 [0x0]
172.16.30.0     172.16.1.248     525 0x80000dc4 0x1c55 E2 172.16.30.0/24
 [0x0]
172.16.30.0     172.16.1.249    1242 0x80000dc3 0x1859 E2 172.16.30.0/24
 [0x0]
172.16.255.0    172.16.1.248    1245 0x8000014e 0x7899 E2 172.16.255.0/24
 [0x0]
192.168.137.0   172.16.1.248     345 0x800008fe 0xec37 E2 192.168.137.0/24
 [0x0]
192.168.137.0   172.16.1.249    1242 0x800008f8 0xf236 E2 192.168.137.0/24
 [0x0]
===========================================================

This is our configure log, does anyone knows how to fix and let route be
established?
Our ospfd conf:
=========================================
password zebra
!
access-list vty permit 127.0.0.0/8
access-list vty deny any
!
line vty
 access-class vty
!
!
interface br0
 ip ospf cost 1
 ip ospf priority 1
!
interface gretunnel
 ip ospf cost 10
 ip ospf priority 1
!
router ospf
 network 172.16.2.0/24 area 0
 network 26.26.26.0/24 area 0
 redistribute connected
 redistribute kernel
!
log syslog
=========================================

Other OSPF equipemnt:
=========================================
ip service all
ip interface "v1" address 172.16.1.248 mask 255.255.255.0 vlan 1 ifindex 1
ip interface "v101" address 10.10.101.1 mask 255.255.255.0 vlan 101 ifindex
2
ip interface "gre_soushan" address 26.26.26.1 mask 255.255.255.0 tunnel
protocol gre source 10.10.101.1 destination 10.10.104.1 ifindex 5

ip load ospf
ip ospf area 0.0.0.0
ip ospf interface "gre_soushan"
ip ospf interface "gre_soushan" area 0.0.0.0
ip ospf interface "gre_soushan" status enable
ip ospf interface "v1"
ip ospf interface "v1" area 0.0.0.0
ip ospf interface "v1" status enable
ip ospf status enable

ip route-map "LOCAL4_OSPF_1" sequence-number 1 action permit
ip route-map "LOCAL4_OSPF_1" sequence-number 1 match ip-address
0.0.0.0/0 redist-control
all-subnets permit
ip route-map "LOCAL4_OSPF_1" sequence-number 1 set metric 1 effect none
ip redist local into ospf route-map "LOCAL4_OSPF_1" status enable
ip redist static into ospf route-map "LOCAL4_OSPF_1" status enable
=========================================

Thanks
James Chan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-dev/attachments/20170214/4d0e2fbb/attachment.html>


More information about the Quagga-dev mailing list