[quagga-dev 16608] Quagga NHRPD / Cisco IOS 15.5(2)T

Patrick Oeschger patrick.oeschger at bluewin.ch
Mon May 1 06:21:26 BST 2017


Hi
Anybody with experience in connecting Cisco IOS to Quagga NHRPD?

IOS config:

interface Tunnel10
 ip address 10.0.0.3 255.255.255.255
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1400
 ip nhrp network-id 1
 ip nhrp nhs dynamic nbma 217.193.211.21
 ip nhrp shortcut
 ip route-cache same-interface
 no ip split-horizon
 ip tcp adjust-mss 1300
 load-interval 30
 tunnel source GigabitEthernet0/0
 tunnel mode gre multipoint
 tunnel protection ipsec profile GRE

*Apr 28 15:16:29.233: NHRP: Send Registration Request via Tunnel10 vrf
0, packet size: 92
*Apr 28 15:16:29.233:  src: 10.0.0.3, dst: 10.0.0.1
*Apr 28 15:16:29.233:  (F) afn: AF_IP(1), type: IP(800), hop: 255, ver: 1
*Apr 28 15:16:29.233:      shtl: 4(NSAP), sstl: 0(NSAP)
*Apr 28 15:16:29.233:      pktsz: 92 extoff: 52
*Apr 28 15:16:29.233:  (M) flags: "unique nat ", reqid: 23
*Apr 28 15:16:29.233:      src NBMA: 194.209.75.37
*Apr 28 15:16:29.233:      src protocol: 10.0.0.3, dst protocol: 10.0.0.1
*Apr 28 15:16:29.233:  (C-1) code: no error(0)
*Apr 28 15:16:29.233:        prefix: 32, mtu: 17916, hd_time: 7200
*Apr 28 15:16:29.233:        addr_len: 0(NSAP), subaddr_len: 0(NSAP),
proto_len: 0, pref: 0
*Apr 28 15:16:29.233: NHRP: Receive Registration Reply via Tunnel10 vrf
0, packet size: 112
*Apr 28 15:16:29.233:  (F) afn: AF_IP(1), type: IP(800), hop: 64, ver: 1
*Apr 28 15:16:29.233:      shtl: 4(NSAP), sstl: 0(NSAP)
*Apr 28 15:16:29.233:      pktsz: 112 extoff: 52
*Apr 28 15:16:29.233:  (M) flags: "unique nat ", reqid: 23
*Apr 28 15:16:29.233:      src NBMA: 194.209.75.37
*Apr 28 15:16:29.233:      src protocol: 10.0.0.3, dst protocol: 10.0.0.1
*Apr 28 15:16:29.233:  (C-1) code: administratively prohibited(4)
*Apr 28 15:16:29.233:        prefix: 32, mtu: 17916, hd_time: 7200
*Apr 28 15:16:29.233:        addr_len: 0(NSAP), subaddr_len: 0(NSAP),
proto_len: 0, pref: 0
*Apr 28 15:16:29.233: %NHRP-3-PAKREPLY: Receive Registration Reply
packet with error - administratively prohibited(4)

Another Linux box connects to DMVPN hub without any issues.
Config should be fine but there seems to be an incompatibility between
Quagga and IOS.
Any inputs/experiences with this issue?
Just saw one thing in source code ... quagga expects prefix 0xff and IOS
seems to report prefix 0x20 (32)
Happy to help dev and test patches if needed :)
BR
/pat



More information about the Quagga-dev mailing list