[quagga-dev 16618] IPv6 BGP routes from a directly connected peer are not accepted in the routing table

Dimitris Kalogeras D.Kalogeras at noc.ntua.gr
Wed May 17 15:35:54 BST 2017


Hi to all of you,

I am using quagga 1.2.1 on a freebsd (10.0) as provided from an already 
compiled packaged.  We are using quagga in the university lab to teach 
routing protocols.

In a simple set up of two connected routers where I setup a direct 
external bgp peering, the routes are exchanged but are not established 
in the routing table as their bgp_nhop is reported as inaccesible 
although it is received from a connected interface.

See the attached image. The configuration of two routers follows..

!
router-a at pc-dkalo:~
! Zebra configuration saved from vty
!   2017/05/16 16:50:22
!
!
interface em0
  ipv6 address fc80:1::1/64
!
interface em1
  ipv6 address fc80:3::1/126
!
interface em2
!
interface em3
!
interface lo0
!
ip forwarding
ipv6 forwarding
!
!
line vty
!
!
! Zebra configuration saved from vty
!   2017/05/16 16:50:22
!
!
router bgp 65010
  bgp router-id 1.1.1.1
  neighbor fc80:3::2 remote-as 65020
! neighbor fc80:3::2 soft-reconfiguration inbound
!
  address-family ipv6
  network fc80:1::/64
  neighbor fc80:3::2 activate
! neighbor fc80:3::2 soft-reconfiguration inbound
  exit-address-family
  exit
!
line vty
!
router-b at pc-dkalo:~#
!
! Zebra configuration saved from vty
!   2017/05/16 17:49:55
!
!
interface em0
  ipv6 address fc80:2::1/64
!
interface em1
  ipv6 address fc80:3::2/126
!
interface em2
!
interface em3
!
interface lo0
!
ipv6 forwarding
!
!
line vty
!
!
! Zebra configuration saved from vty
!   2017/05/16 17:49:55
!
!
router bgp 65020
  bgp router-id 2.2.2.2
  neighbor fc80:3::1 remote-as 65010
!
  address-family ipv6
  network fc80:2::/64
  neighbor fc80:3::1 activate
  exit-address-family
  exit
!
line vty
!


-- 
Cheers,
Dimitris
--
Dimitrios K. Kalogeras

Electrical Engineer Ph.D.
Network Engineer
NTUA/ICCS
  _____________________________________
  skype: aweboy
  voice: +30-210-772 1863
  fax: +30-210-772 1866
-------------- next part --------------
A non-text attachment was scrubbed...
Name: VirtualBox_Quagga_2_17_05_2017_17_33_09.png
Type: image/png
Size: 11778 bytes
Desc: not available
URL: <http://lists.quagga.net/pipermail/quagga-dev/attachments/20170517/320e93b2/attachment.png>


More information about the Quagga-dev mailing list