Hi David <div><br></div><div>&gt;just to state the obvious: Balaji&#39;s SAFI patches broke zserv protocol<br>&gt;compatibility by introducing a new field into existing messages. </div><div><br></div><div>Oh sorry for hat, i could fix this and send an updated patch or would you be doing this along with the PIM merge ?</div>
<div><br></div><div>Let me know</div><div><br></div><div>Thanks,</div><div>Cheers,</div><div>  - Balaji<br><br><div class="gmail_quote">On Thu, Feb 16, 2012 at 11:30 AM, David Lamparter <span dir="ltr">&lt;<a href="mailto:equinox@diac24.net">equinox@diac24.net</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi everyone,<br>
<br>
<br>
just to state the obvious: Balaji&#39;s SAFI patches broke zserv protocol<br>
compatibility by introducing a new field into existing messages.<br>
<br>
I don&#39;t really have much of a problem with this, but I guess we should<br>
increase the protocol version number. Alternatively, we can fix it<br>
before making the next release.<br>
<br>
Out-of-quagga zserv implementations /do/ exist, most notably in olsrd&#39;s<br>
old quagga plugin (which should not be used in favour of the new one<br>
which uses libzebra, cf. <a href="http://git.nowhere.ws/?p=olsrd-zclient.git" target="_blank">http://git.nowhere.ws/?p=olsrd-zclient.git</a> )<br>
Funnily enough I know personally know the authors of both plugins :)<br>
<br>
<br>
-David<br>
_______________________________________________<br>
Quagga-dev mailing list<br>
<a href="mailto:Quagga-dev@lists.quagga.net">Quagga-dev@lists.quagga.net</a><br>
<a href="http://lists.quagga.net/mailman/listinfo/quagga-dev" target="_blank">http://lists.quagga.net/mailman/listinfo/quagga-dev</a><br>
</blockquote></div><br></div>