[quagga-users 3431] Re: Anyone on this list

Paul Jakma paul at clubi.ie
Wed Dec 15 23:20:47 GMT 2004


On Wed, 15 Dec 2004, Sean Fulton wrote:

> I did try it with the correct netmask/broadcast address on eth0 but it still 
> had the same problem. I've used this config for eight years with gated on 
> various redhat boxes and it worked flawlessly. The ifconfig command was 
> always just:
>
>       ifconfig eth0:$count $a netmask 255.255.255.255 up            route 
> add -host $a eth0:$count

But the broadcast didnt match that netmask, i thought.

However, we should probably weed out non-PtP /32s from consideration 
as RIP interfaces.

> where $a is the virtual IP and $count is a sequential number. 
> However we just upgraded (in August) to RedHat 9,

Something like:

 	interface lo
 	  192.168.0.X/24

in zebra.conf would be far less clutter ;) (substitute appropriate 
prefix obviously) - and wouldnt cause problems.

> and I think that is where the broadcast addresses got screwed up. I 
> hadn't noticed that until today. I did some digging and found that 
> ifconfig now supports specifying the broadcast address as well, so 
> I changed it to:
>
>       ifconfig eth0:$count $a broadcast $a netmask 255.255.255.255 up 
> route add -host $a eth0:$count
>
> And as far as the addresses go, everything was correct (correct 
> broadcast for both RIP and the kernel).
>
> Even so, quagga wasn't working it out correctly, so there must still be some 
> kind of bug.

Well, why does a /32 have a broadcast address? That's wrong for a 
start. Change the above to:

  ip address add ${a}/32 dev eth0 label eth0:${count}

And unless you absolutely must have the address show up, I'd advise 
simply removing the "label eth0:${count}".

> If you need me to test some patches or a potential fix, I'd be glad 
> to do it. I'll leave the addressses on lo for now because I don't 
> see any drawbacks to it. But as I said, RedHat does prefer using 
> eth0, and since it seemed to work in Zebra (and gated), this could 
> be a nasty gotcha for anyone upgrading.

Well, its a really weird configuration. If you had them as /30 or 
bigger prefixes (eg a /24, with the broadcast correct for /24) I 
suspect it'd have worked - or at least, if it hadnt *that* would be a 
genuine bug.

Note that I think redhat's sysconfig method for generating device 
aliases creates 'normal' netmask/broadcast addresses.

> I had ripd dying because it had generated 2G of errors in 1 day and couldn't 
> write to the log file any more!

Andrew has fixed this.

> Thanks again for the help.

No worries!

> sean

regards
-- 
Paul Jakma	paul at clubi.ie	paul at jakma.org	Key ID: 64A2FF6A
Fortune:
How often I found where I should be going only by setting out for somewhere
else.
 		-- R. Buckminster Fuller


More information about the Quagga-users mailing list