[quagga-users 3591] Re: Quagga 0.98.0 vtysh compile failure NetBSD 2.0 Intel

Gernot W. Schmied gernot.schmied at chello.at
Mon Jan 10 10:53:53 GMT 2005


Ricky Wibowo wrote:
> you must install libreadline4-dev first
> 
> Gernot W. Schmied wrote:
> 
>> Greg Troxel wrote:
>>
>>> Probably you need the readline package from ports; that's how it works
>>> on NetBSD (pkgsrc/devel/readline).  Older readlines are missing some
>>> functions, at least from the newer readline perspective.  We should
>>> perhaps add a configure test for those, and either cope or fail; right
>>> now vtysh.c does not ifdef the readline include.
>>>
>>>
>>
>> I am positive libreadline.a can be found on the system now.
>> ./configure still complains about
>>
>> checking for main in -lreadline... no
>> configure: error: vtysh needs libreadline but was not found and usable 
>> on your system.
>>
>>
>> Is readline-4.3 ok? Version mismatch?
>>
>> Thanks,
>> Gernot

Hmm,

The only readline package available on NetBSD 2.0 pkgsrc is 
readline-4.3. Did I misunderstand you? It produces the appropriate .a 
and .so libraries.

Gernot


More information about the Quagga-users mailing list