[quagga-users 7567] two bgp routers

peceka peceka at gmail.com
Thu Sep 21 13:01:42 IST 2006


Hi,

i've set two routers (freebsd) with quagga (quagga-0.99.4).
rtr1 is connected to ISP1 and rtr2 is connected to ISP2.
rtr1 and rtr2 are connected with each other.

schema is on http://img240.imageshack.us/my.php?image=bgp1gz3.jpg

when i do on rtr1:
rtr1# echo -n "isp1: " ; netstat -rn | grep "10.1.1.1" | wc -l ; echo
-n "isp2: " ; netstat -rn | grep "192.168.1.2" | wc -l

i get:
isp1:   170255
isp2:    25588

On rtr2:
rtr2# echo -n "isp1: " ; netstat -rn | grep "192.168.1.1" | wc -l ;
echo -n "isp2: " ; netstat -rn | grep "10.2.1.1" | wc -l
isp1:    56480
isp2:   133875

Why rtr1 and rtr2 hasn't returned me the same values?

Then i want to connect to these routers another one (rtr3) with ospf
(this will be router for my LAN).

I compiled quagga from OpenBSD ports (quagga-0.96.4) with option
--enable-multipath=3.
i've connected all three routers with ospf and now:
rtr3# netstat -rn | grep default
default            192.168.1.1       UG1         1      632      -   rl1

So in this configuration link to ISP1 is more utilized then link to ISP2.
Even if I traceroute from rtr3 to website of ISP2, which is in its
network, my packets goes to ISP1 then somewhere goes to ISP2 and then
connect to this website.
Is it normal? Or mabye my configuration is wrong?

rtr1# cat bgpd.conf
!
! Zebra configuration saved from vty
!   2006/09/20 21:01:40
!
hostname rtr1-bgpd
log syslog
!
router bgp ABCDE
 bgp router-id 192.168.1.1
 bgp dampening
 network 192.168.1.0/24
 aggregate-address 192.168.1.0/24
 neighbor 10.1.1.1 remote-as ASISP1
 neighbor 10.1.1.1  description ISP1
 neighbor 10.1.1.1  update-source ste1
 neighbor 10.1.1.1  prefix-list justmyprefix out
 neighbor 10.1.1.1  route-map notransit out
 neighbor 192.168.1.2 remote-as ABCDE
 neighbor 192.168.1.2 description RTR2 - iBGP
!
ip prefix-list justmyprefix seq 1 permit 192.168.1.0/24
ip prefix-list justmyprefix seq 100 deny any
!
ip as-path access-list justme permit ^$
!
route-map notransit permit 10
 match as-path justme
!
line vty
!
rtr1-futuro# cat ospfd.conf
!
! Zebra configuration saved from vty
!   2006/09/20 20:58:13
!
!
!
!
interface lo0
!
interface pflog0
!
interface pfsync0
!
interface ste0
!
interface ste1
!
interface ste2
!
interface ste3
!
interface vr0
!
router ospf
 network 195.182.23.0/24 area 0.0.0.0
 default-information originate always
!
line vty
!

rtr1# cat ospfd.conf
!
! Zebra configuration saved from vty
!   2006/09/20 20:58:13
!
!
!
!
interface lo0
!
interface pflog0
!
interface pfsync0
!
interface ste0
!
interface ste1
!
interface ste2
!
interface ste3
!
interface vr0
!
router ospf
 network 192.168.1.0/24 area 0.0.0.0
 default-information originate always
!
line vty
!

rtr2# cat bgpd.conf
!
! Zebra configuration saved from vty
!   2006/08/09 14:54:27
!
hostname rtr2-bgpd
!!
router bgp ABCDE
 bgp router-id 192.168.1.2
 bgp dampening
 network 192.168.1.0/24
 aggregate-address 192.168.1.0/24
 neighbor 192.168.1.1 remote-as ABCDE
 neighbor 192.168.1.1 description RTR1
 neighbor 10.2.2.1 remote-as ASISP2
 neighbor 10.2.2.1 description ISP2
 neighbor 10.2.2.1 ebgp-multihop 255
 neighbor 10.2.2.1 update-source rl0
 neighbor 10.2.2.1 soft-reconfiguration inbound
 neighbor 10.2.2.1 prefix-list justmyprefix out
 neighbor 10.2.2.1 route-map notransit out
!
ip prefix-list justmyprefix seq 1 permit 192.168.1.0/24
ip prefix-list justmyprefix seq 100 deny any
!
ip as-path access-list justme permit ^$
!
route-map notransit permit 10
 match as-path justme
!
line vty
!

rtr2# cat ospfd.conf
!
! Zebra configuration saved from vty
!   2006/08/09 14:54:26
!
!
!
!
interface lo0
!
interface plip0
!
interface rl0
!
interface rl1
!
interface vr0
!
router ospf
 network 192.168.1.0/24 area 0.0.0.0
 default-information originate always
!
line vty
!



rtr3# cat ospfd.conf
!
! Zebra configuration saved from vty
!   2006/09/20 20:26:33
!
hostname rtr3
!
!
!
interface carp0
!
interface carp1
!
interface enc0
!
interface lo0
!
interface pflog0
!
interface pfsync0
!
interface rl0
!
interface rl1
!
interface ste0
!
interface ste1
!
interface ste2
!
interface ste3
!
interface vr0
!
router ospf
 network 192.168.1.0/24 area 0.0.0.0
!
line vty
!

Regards,
p


More information about the Quagga-users mailing list