[quagga-users 9291] prepending our annunce only about some network

Rosario Pingaro rpingar at nesec.it
Fri Jan 18 08:52:39 GMT 2008


Hi,

we annunce 5 networs to two upstreeam providers. I would like to do a path prepending only on 2 of this networks to the first provider.
Is it possible? What is the best way to do it?
I know I have to work on the 

route-map first-provider out

But i dont get howto.

Thanks about the help.

Regards 
Rosario


  ----- Original Message ----- 
  From: Jorge Evangelista 
  To: quagga-users at lists.quagga.net 
  Sent: Thursday, January 17, 2008 11:51 AM
  Subject: [quagga-users 9289] Re: Virtual Interface support


  Try to add this command "no ip rip authentication mode" in WAN interfaces of  both routers,  you will not see it when you execute  "show run"


  linux-gw# vtysh 
  Hello, this is Quagga (version 0.98.3).
  Copyright 1996-2005 Kunihiro Ishiguro, et al.
  router#
  router#conf t
  router(config)#interface eth2
  router(config-if)#no ip rip authentication mode
  router(config-if)#exit
  router(config)#exit
  router#wr


  Regards


   
  On Jan 16, 2008 12:07 PM, Dalibor Toman <dtoman at fortech.cz> wrote:

    Hi,

    On Saturday, January 12, 2008 3:05 PM ,

    Shashi Lad <shashilad at fastmail.fm> wrote:

    >
    > I m running quagga in my Linux system to route packet.
    >
    > I have created to virtual interfaces of eth0 by creating 2 vlan 
    > [using
    > vconfig] on it.



    I don't know RIP too much but I can say this:
     - I am using quagga to run  OSPF over VLAN interfaces on linux and I
    have no problems with it
     - to be sure - are you running the zebra and ripd on BOTH linux 
    boxes?
    -  do you have forwarding enabled?

    D. Toman


    > ripd is running in Linux system. But routing is not happening in
    > system.
    >
    > Topology:
    >
    >
    >
    >                    Linux-1                           Linux-2 
    >                   ______________ 
    >                   |             |
    > PC1     ---------- |eth0         |                    ________
    > 10.10.10.10/8      |             |                    |       | 
    >                   |         eth2|====================| eth0  |
    >                   |             |                    |       |
    > PC2     ---------- |eth1         |                    |_______| 
    > 20.20.20.20/8      |             |
    >                   |_____________|
    >
    >
    > There is trunk link between eth2 of linux-1 and eth0 of linux-2 
    > 
    > Zebra and rip daemon is running on Linux-2
    >
    > Following command i have run for virtual interfce
    >
    > Linux-2:
    >
    > vconfig add eth0 10
    > vconfig add eth0 20
    > ifconfig eth0.10 10.10.10.12/8 up
    > ifconfig eth0.20 20.20.20.22/8 up
    >
    > Rip configuration
    >
    > router rip 
    > network 10.0.0.0/8
    > network 20.0.0.0/8
    > version 2
    >
    >
    > With this configuration it should route the packet. 
    > But it not working for me.
    >
    >
    > I m new to this things.
    >
    > Any help will be appreciated.
    >
    > Thanks in advance,
    > SHashi



    _______________________________________________
    Quagga-users mailing list
    Quagga-users at lists.quagga.net
    http://lists.quagga.net/mailman/listinfo/quagga-users




  -- 
  "The network is the computer" 


------------------------------------------------------------------------------


  _______________________________________________
  Quagga-users mailing list
  Quagga-users at lists.quagga.net
  http://lists.quagga.net/mailman/listinfo/quagga-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.quagga.net/pipermail/quagga-users/attachments/20080118/35a44d5d/attachment.htm


More information about the Quagga-users mailing list