[quagga-users 10116] Re: [Quagga] About OSPF routing

Kim, Dongchan hajadc at gatech.edu
Tue Nov 11 00:45:49 GMT 2008


I'm sorry, but I'm not an expert.
Can you give me more specific details?
You mean I should make change on 'network x.x.x.x/y area z'?

----- 원본 메시지 -----
보낸 사람: "Bret Clark" <bclark at spectraaccess.com>
받는 사람: "." <quagga-users at lists.quagga.net>
보낸 시간: 2008년 11월 10일, 월요일 오후 5:49:12 GMT -05:00 미국/캐나다 동부
제목: [quagga-users 10113] Re: [Quagga] About OSPF routing

This doesn't look right if I understand your config

> O   155.98.36.0/22 [110/20] via 10.1.1.3, eth0, 01:55:55
                            via 10.1.2.3, eth3, 01:55:55
                            via 10.1.5.3, eth4, 01:55:55
> C>* 155.98.36.0/22 is directly connected, eth2

This says you have one big flat network through out your config since it
s showing that's it's available on all your interfaces. Split the
network up between the 2 nodes. 



-----Original Message-----
From: quagga-users-bounces at lists.quagga.net
[mailto:quagga-users-bounces at lists.quagga.net] On Behalf Of Kim,
Dongchan
Sent: Monday, November 10, 2008 4:15 PM
To: .
Subject: [quagga-users 10112] [Quagga] About OSPF routing

Hello.

I have a question about configuration.

Now I'm testing on emulab.
And I installed quagga on each node and run as daemon mode.

The topology is like this:
node1 - router1 - router2 - node4
             \     /
             router3

<<router1 zebra conf>>
hostname router1
password 1
enable password 1

interface eth4
   ip address 10.1.5.2/24
interface eth0
   ip address 10.1.1.2/24
interface eth3
   ip address 10.1.2.2/24

access-list vty permit 127.0.0.1/32

log file /users/hajadc/log/r1.log

<<router1 ospf conf>>
hostname router1
password 1
enable password 1

interface eth0
   ip ospf cost 1
interface eth4
   ip ospf cost 1
interface eth3
   ip ospf cost 1

router ospf
   ospf router-id 10.1.5.2
   network 10.1.1.0/24 area 0
   network 10.1.2.0/24 area 0
   network 10.1.5.0/24 area 0
   redistribute connected
   redistribute static

log stdout

To make it possible, I enabled ip forwarding(net.ipv4.ip_forward=1).
But when I ping node4 from node1, node4 is unreachable.

When I see the table inside zebra,
router1> show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
       I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 155.98.36.1, eth2
O   10.1.1.0/24 [110/1] is directly connected, eth0, 02:02:56
C>* 10.1.1.0/24 is directly connected, eth0
O   10.1.2.0/24 [110/1] is directly connected, eth3, 02:02:51
C>* 10.1.2.0/24 is directly connected, eth3
O>* 10.1.3.0/24 [110/2] via 10.1.1.3, eth0, 01:58:34
                        via 10.1.2.3, eth3, 01:58:34
O>* 10.1.4.0/24 [110/2] via 10.1.2.3, eth3, 01:59:44
O   10.1.5.0/24 [110/1] is directly connected, eth4, 02:02:51
C>* 10.1.5.0/24 is directly connected, eth4
K * 127.0.0.0/8 is directly connected, lo
C>* 127.0.0.0/8 is directly connected, lo
O   155.98.36.0/22 [110/20] via 10.1.1.3, eth0, 01:55:55
                            via 10.1.2.3, eth3, 01:55:55
                            via 10.1.5.3, eth4, 01:55:55
C>* 155.98.36.0/22 is directly connected, eth2
K>* 169.254.0.0/16 is directly connected, lo

I think ospf works fine, but when I type "route", I can't see other
nodes than neighbors.
Also, when I see the traffic through router1, router1 just listens the
arp packet but does not transfer to other nodes.

Can anyone help me solve this?

Thanks

-- 
Sincerely,




Dongchan Kim
hajadc at gatech.edu
_______________________________________________
Quagga-users mailing list
Quagga-users at lists.quagga.net
http://lists.quagga.net/mailman/listinfo/quagga-users

_______________________________________________
Quagga-users mailing list
Quagga-users at lists.quagga.net
http://lists.quagga.net/mailman/listinfo/quagga-users

-- 
Sincerely,




Dongchan Kim
hajadc at gatech.edu


More information about the Quagga-users mailing list