[quagga-users 10027] ospf neighbor lost with dead-interval minimal and ntp

Francesco Dolcini fdolcini at sysnetsistemi.it
Mon Oct 20 09:26:31 IST 2008


I have a problem with ospf dead-interval minimal when using ntp, 
sometime the neighbor association is lost when the ntp client modify the 
date, here a log:

Oct 15 08:46:39 ntpclient: # box [( -99.804 , -177330.4 )  ( 61.543 , 
72659.5 )]  delta_f 0.108  computed_freq 1279021
Oct 15 08:46:39 ntpclient: 39734 24399.613    5758.0     42.9  -10924.7 
273757.9   1286127
Oct 15 08:49:39 ntpclient: # box [( -109.779 , -200720.7 )  ( 68.124 , 
87252.3 )]  delta_f 0.104  computed_freq 1272193
Oct 15 08:49:39 ntpclient: 39734 24579.599    2035.0     40.1  -42328.7 
276458.7   1279021
Oct 15 08:49:39 ospfd[39]: nsm_change_state(10.1.1.2, Full -> Deleted): 
scheduling new router-LSA origination
Oct 15 08:49:39 ospfd[39]: Link State Update: Unknown Neighbor 10.1.1.2 
on int: loopA:10.1.2.3
Oct 15 08:49:39 ospfd[39]: Packet[DD]: Neighbor 10.1.1.2: Initial DBD 
from Slave, ignoring.
Oct 15 08:49:44 ospfd[39]: Packet[DD]: Neighbor 10.1.1.2: Initial DBD 
from Slave, ignoring.
Oct 15 08:49:44 ospfd[39]: Packet[DD]: Neighbor 10.1.1.2 Negotiation 
done (Master).
Oct 15 08:49:44 ospfd[39]: nsm_change_state(10.1.1.2, Exchange -> Full): 
scheduling new router-LSA origination

I am using quagga 0.99.11 and the interface are configured this way:
  ip ospf dead-interval minimal hello-multiplier 4
  ip ospf network point-to-point
  link-detect

If I disable the ntpclient or use a greater hello time and dead interval 
(1sec hello time and 4sec dead interval) everything is ok.

I have read quagga-dev #5840 and tried Joakim Tjernlund patch with no 
luck (no LSA sent using his patch). I can't try CLOCK_MONOTONIC since I 
am using an old kernel (2.4).

Any hint?

thanks
Francesco




More information about the Quagga-users mailing list