[quagga-users 9950] OSPF route flip-flap after subnet extension

Nick King mr_king at optilian.com
Mon Sep 29 15:25:34 IST 2008

Hi all,

--- Introduction and problem description ---

I've an OSPF routed network with several areas, following some changes
in the logical network topology (a /30 became a /29), I've a problem
that I'm unable to solve.

NOTE: Reals IPs addresses have been changed to fake ones since this is a
production network.

Here is a small schema which could help to get the picture more easily
[area 0] <--- router-id ---> [area]

The problem is that the announce of area (now but previously on the area 0 is
inconsistent. Basically it's "Link ID" and "Route" change from time to
time and cause some sort of network flip/flap from machines on the
backbone (area 0) to this network.

Last but not least, I'm using Quagga 0.99.5 (debian Etch version) on all
members routers of area In area 0, there is a mix of
0.98.3 and 0.99.5 but since this is not where the problem is coming
from, I think we can concentrate on the latest release.

Here are the interesting bit and pieces of the config

--- zebra # show ip ospf interface eth1
eth1 is up
  ifindex 5, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
  Internet Address, Broadcast, Area
  MTU mismatch detection:enabled
  Router ID, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DROther, Priority 1
  Designated Router (ID), Interface Address
  Backup Designated Router (ID), Interface Address
  Multicast group memberships: OSPFAllRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 4.074s
  Neighbor Count is 2, Adjacent neighbor count is 2

--- ospfd.conf

router ospf
ospf router-id
redistribute connected route-map OPTLN
redistribute static route-map CERT
passive-interface eth4
passive-interface ppp0
network area
network area
network area
network area
network area
access-list OPTLN permit
access-list OPTLN deny any
route-map OPTLN permit 5
match ip address OPTLN

--- interesting info from "show ip ospf database self-originate"

       OSPF Router with ID (

                Router Link States (Area

Link ID         ADV Router      Age  Seq#       CkSum  Link count     68 0x80001ab6 0x14e6 1

                Summary Link States (Area

Link ID         ADV Router      Age  Seq#       CkSum  Route   1154 0x8000196b 0x839f    224 0x8000196b 0x0320   1524 0x80001a94 0x3da3    124 0x80000e8c 0x992c

                Summary Link States (Area

Link ID         ADV Router      Age  Seq#       CkSum  Route   1116 0x80000021 0xe2a3   1266 0x80000021 0x72fb   1106 0x80000020 0xe264

                Summary Link States (Area

Link ID         ADV Router      Age  Seq#       CkSum  Route    403 0x80000081 0xa283   1213 0x80000022 0xe0a4   1533 0x80000021 0xe065

--- Comments on last command
Within area 0, Link ID is with a route of, notice the incorrect Link ID ""
Within others areas, Link ID is with a route of which is correct

Sometime the incorrect announce on area 0 has others values like:   3600 0x80001fc2 0x5829
or even a correct one:    233 0x80000da0 0x743e
but they don't stay long and the incorrect one shown in the first
example come back:    124 0x80000e8c 0x992c

What I can see very very often in OSPF logs (with minimum debug) of all
area 0 routers  is the following lines:
2008/09/25 16:33:39 OSPF: Link State
Update[Type3,id(,ar(]: LS age is equal to
2008/09/25 16:38:16 OSPF: Link State
Update[Type3,id(,ar(]: LS age is equal to

All this cause the route to the network to be removed
for a short amount of time for all area 0 routers... and just in this
area, for the others everything works fine.

--- Self Analysis and Conclusion ---

For some reasons, there seems to be several overlaping information about
the network in ospf router
I've tried to remove the "network area" from all routers of this area and put it back, I've
tried to disable the interface in zebra and put it back... but nothing
has changed, I still have my problem.

I would be glad if someone could help me to find out what's wrong, maybe
there is some bug around but my OSPF skills aren't high enough to affirm

Best regards, Nick.

More information about the Quagga-users mailing list