[quagga-users 10990] [OSPFv2] Problem with neighbor adjacency

Maciej Drobniuch wdcapl at gmail.com
Wed Aug 5 08:49:37 IST 2009


Hi all!
I have five ethernet interfaces(eth0-eth4). eth0 is an integrated card(via)
and eth1-eth4 is an all in one gigabit ethernet card(4 ports, probably based
on rt8139). OSPF runs on eth0 and eth4. The problem is that quagga can't see
neigboards on eth4, the adjacency works perfectly on eth0.
I've changed in the /etc/udev/rules/75-network... the interfaces attached to
eth0 and eth4, i've switched them physicly and logicaly, so the
configuration files are the same. Now the adjacency is working on eth4 and
not on eth0. What is interesting the neighboar of the interface that isn't
working sees the quagga router in INIT state.

My configuration:
zebra.conf
! -*- zebra -*-
!
! zebra sample configuration file
!
! $Id: zebra.conf.sample,v 1.1.1.1 2002/12/13 20:15:30 paul Exp $
!
hostname localhost
password sdfsdf
!
! Interface's description.
!
!interface lo
! description test of desc.
!
!interface sit0
! multicast

interface eth0
 ip address 82.0.0.245/30
 multicast

interface eth4
 ip address 82.0.0.210/30
 multicast

!interface eth2
! ip address 192.168.0.1/24
! multicast

!
! Static default route sample.
!
#ip route 0.0.0.0/0 83.13.157.161
!

log file zebra.log


ospfd.conf
! -*- ospf -*-
!
! OSPFd sample configuration file
!
!
hostname ospfd
password tereferekuku
!enable password please-set-at-here
!
router ospf
  ospf router-id 82.0.0.210
  network 82.0.0.244/30 area 0
  network 82.0.0.210/30 area 0
  !default-information originate always
  !redistribute static
  redistribute connected
!
!interface eth4
! ip ospf cost 10
! ip ospf hello-interval 10
! ip ospf dead-interval 40
! ip ospf retransmit-interval 5
! ip ospf priority 1
! ip ospf transmit-delay 1
!
log stdout
log file ospfd.log

ospfd.log:
2009/08/05 04:48:56 OSPF: OSPFd 0.99.13 starting: vty at 2604
2009/08/05 04:48:56 OSPF: interface 82.0.0.245 [5] join AllSPFRouters
Multicast group.
2009/08/05 04:48:56 OSPF: interface 82.0.0.210 [6] join AllSPFRouters
Multicast group.
2009/08/05 04:48:59 OSPF: ospfTrapNbrStateChange trap sent: 82.160.22.209
now Init/DROther
2009/08/05 04:49:02 OSPF: DR-Election[1st]: Backup 82.0.0.210
2009/08/05 04:49:02 OSPF: DR-Election[1st]: DR     82.0.0.209
2009/08/05 04:49:02 OSPF: DR-Election[2nd]: Backup 82.0.0.210
2009/08/05 04:49:02 OSPF: DR-Election[2nd]: DR     82.0.0.209
2009/08/05 04:49:02 OSPF: ospfTrapIfStateChange trap sent: 82.0.0.210 now
Backup
2009/08/05 04:49:02 OSPF: interface 82.0.0.210 [6] join AllDRouters
Multicast group.
2009/08/05 04:49:02 OSPF: DR-Election[1st]: Backup 82.00.0.210
2009/08/05 04:49:02 OSPF: DR-Election[1st]: DR     82.0.0.209
2009/08/05 04:49:02 OSPF: Packet[DD]: Neighbor 192.168.127.1 Negotiation
done (Slave).
2009/08/05 04:49:07 OSPF: nsm_change_state(192.168.127.1, Loading -> Full):
scheduling new router-LSA origination
2009/08/05 04:49:36 OSPF: DR-Election[1st]: Backup 82.0.0.245
2009/08/05 04:49:36 OSPF: DR-Election[1st]: DR     82.0.0.245
2009/08/05 04:49:36 OSPF: DR-Election[2nd]: Backup 0.0.0.0
2009/08/05 04:49:36 OSPF: DR-Election[2nd]: DR     82.0.0.245
2009/08/05 04:49:36 OSPF: ospfTrapIfStateChange trap sent: 82.0.0.245 now DR
2009/08/05 04:49:36 OSPF: interface 82.0.0.245 [5] join AllDRouters
Multicast group.

192.168.127.1 is the router behind eth4(via card)
82.0.0.246 is the router behind(eth0) the combo card based on rtl8139

Could someone tell me howto debug logs and put out the useful stuf?
Thanks for suggestions and sorry for my lame eng.
Best wishes
Maciej Drobniuch
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.quagga.net/pipermail/quagga-users/attachments/20090805/3f4b2851/attachment.html 


More information about the Quagga-users mailing list