[quagga-users 12315] ipv6 and ipv4 peer in the one vlan

Zigmunds Vītiņš zvitins at tcp.lv
Thu Jun 2 18:53:48 IST 2011


Hi all,

I have running quagga (version 0.99.17)  with few peer's based on ipv4 
and all working fine.
Now I want to test IPv6.
I put IP on the interface:

interface eth1.123
  description test-peer
  ip address 1.1.1.50/29
  ipv6 address 2a02:xxxx:xxxx:xxxx::2/64
  ipv6 nd suppress-ra

bgp config:

router bgp 123
  bgp router-id 1.1.1.50
  network 2.2.2.2/24
  neighbor 1.1.1.51 remote-as 124
  neighbor 1.1.1.51 next-hop-self
  neighbor 1.1.1.51 route-map RM_IN in
  neighbor 1.1.1.51 route-map RM_OUT out
  neighbor 2a02:xxxx:xxxx:xxxx::1 remote-as 124
  neighbor 2a02:xxxx:xxxx:xxxx::1 description IPv6

address-family ipv6
  network 2a00:xxxx::/32
  exit-address-family

 From Linux I can ping and see ipv6 addresses on other router (Cisco), 
but peer is down:

"sh ip bgp summary"

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  
State/PfxRcd
178.16.31.6     4 124  420779  376820        0    0    0 10:18:44        1
2a02:xxxx:xxxx:xxxx::1  4 124     153     155        0    0    0 
never    Idle

"sh ipv6 bgp summary"
No IPv6 neighbor is configured


In quagga logs are message:
2011/06/02 20:36:19 BGP: message index 8 not found (max is 8)
2011/06/02 20:38:34 BGP: message index 8 not found (max is 8)

In logs on Cisco router are:

EET: %BGP_SESSION-5-ADJCHANGE: neighbor 2a02:xxxx:xxxx:xxxx::1IPv6 
Unicast topology base removed from session  Peer closed the session

what is wrong in my configuration?

Thanks.
Zigmunds



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20110602/ae445532/attachment.html>


More information about the Quagga-users mailing list