[quagga-users 12331] Problems using OSPF as failover

Nataniel Klug listas.nata at cnett.com.br
Mon Jun 6 18:48:05 IST 2011


                Hello all,

 

                I am having some troubles configuring a network using OSPF
and failover in my network. The picture attached to this email show the
exact configuration of my network (in this picture I am using fake IPs). The
problem occur when I turn OSPFd on in both CACHE (01 and 02) and, for sure,
the AUTH will have 2 different gateways. The CLIENTE machine now start to
drop packets from it to ROUTER. When I turn off OSPFd on CACHE.01 or
CACHE.02, putting AUTHs with just 1 gateway, the network work fine.

 

                I tried different options using NBMA networks between CACHEs
and AUTHs but no luck with that. I tried to set everything using just
Mikrotik RoS v5.4 and it worked fine (in my lab).

 

                I am pretty sure that the problem is somewhere between the
Linux (CentOS v5.4) and Quagga but I can’t find where is it.

 

                Can someone help me with that? Bellow are my configurations
for CACHE.01 and CACHE.02:

 

[root at 01 ~]# cat /etc/quagga/ospfd.conf

! Configuracao do OSPFd

hostname LJS.CACHE.01

 

interface eth0

interface eth1

interface lo

 

router ospf

        ospf router-id 172.16.99.16

        network 172.16.99.16/32 area 0.0.0.0

        network 10.251.144.0/30 area 0.0.0.0

       network 10.31.0.0/30 area 0.0.0.0

       network 10.31.0.4/30 area 0.0.0.0

 

log stdout

[root at 02 ~]# cat /etc/quagga/ospfd.conf

! Configuracao do OSPFd

hostname LJS.CACHE.02

 

interface eth0

interface eth1

interface lo

 

router ospf

        ospf router-id 172.16.99.17

        network 172.16.99.17/32 area 0.0.0.0

        network 10.251.144.16/30 area 0.0.0.0

       network 10.31.0.8/30 area 0.0.0.0

       network 10.31.0.12/30 area 0.0.0.0

 

log stdout

 

--

Descrição: Descrição: 20110500 - EMAIL-SIGN - CAPADescrição: Descrição:
20110500 - EMAIL-SIGN - nata

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20110606/78e63655/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/gif
Size: 33701 bytes
Desc: not available
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20110606/78e63655/attachment-0002.gif>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/gif
Size: 13540 bytes
Desc: not available
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20110606/78e63655/attachment-0003.gif>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Desenho1.png
Type: image/png
Size: 166284 bytes
Desc: not available
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20110606/78e63655/attachment-0001.png>


More information about the Quagga-users mailing list