[quagga-users 12536] quaga problems : routes does not redistribute in kernel

Iulian Craciunescu iulian.c at emvatelecom.ro
Thu Oct 27 20:31:53 IST 2011


I even restarted bgpd process , here are mu outputs from bgpd:
bgpd# sh ip bgp sum
BGP router identifier 195.191.198.1, local AS number 50642
RIB entries 690158, using 42 MiB of memory
Peers 2, using 5048 bytes of memory

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down
State/PfxRcd
188.209.98.245  4  6910    6188  161124        0    0    0 11:45:54    
14762
188.209.98.249  4  6910  237745    5404        0    0    0 11:45:51   
373300

Total number of neighbors 2
bgpd#
bgpd# show ip route
% [BGP] Unknown command: show ip route
bgpd#
ip bgp neighbors 188.209.98.245 received-routes
BGP table version is 0, local router ID is 195.191.198.1
Status codes: s suppressed, d damped, h history, * valid,>  best, i -
internal,
                r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete

     Network          Next Hop            Metric LocPrf Weight Path
*>  31.2.128.0/21    188.209.98.245                         0 6910 20530
5606 49663 i
*>  31.2.136.0/21    188.209.98.245                         0 6910 20530
5606 49663 i
*>  31.2.144.0/21    188.209.98.245                         0 6910 20530
5606 49663 i
*>  31.2.152.0/21    188.209.98.245                         0 6910 20530
5606 49663 i
*>  31.2.160.0/21    188.209.98.245                         0 6910 20530
5606 50151 i
*>  31.2.168.0/22    188.209.98.245                         0 6910 20530
5606 50151 i
*>  31.2.172.0/22    188.209.98.245                         0 6910 20530
5606 50151 i
*>  31.2.176.0/22    188.209.98.245                         0 6910 20530
5606 50151 i
   --More--
ip bgp neighbors 188.209.98.245 routes
BGP table version is 0, local router ID is 195.191.198.1
Status codes: s suppressed, d damped, h history, * valid,>  best, i -
internal,
                r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete

     Network          Next Hop            Metric LocPrf Weight Path
*>  31.2.128.0/21    188.209.98.245                         0 6910 20530
5606 49663 i
*>  31.2.136.0/21    188.209.98.245                         0 6910 20530
5606 49663 i
*>  31.2.144.0/21    188.209.98.245                         0 6910 20530
5606 49663 i
*>  31.2.152.0/21    188.209.98.245                         0 6910 20530
5606 49663 i
*>  31.2.160.0/21    188.209.98.245                         0 6910 20530
5606 50151 i
*>  31.2.168.0/22    188.209.98.245                         0 6910 20530
5606 50151 i
*>  31.2.172.0/22    188.209.98.245                         0 6910 20530
5606 50151 i
*>  31.2.176.0/22    188.209.98.245                         0 6910 20530
5606 50151 i
   --More--
this is my bgpd.conf now:
!
! Zebra configuration saved from vty
!   2010/03/15 01:53:07
!
hostname bgpd
password xxxxxxxxxxx
enable password xxxxxxxxxxxx
log file /var/log/quagga/bgpd.log
!debug bgp
debug bgp events
!debug bgp keepalives
debug bgp updates
!debug bgp fsm
!debug bgp filters
log stdout
!
bgp config-type cisco
!
!bgp mulitple-instance
!
router bgp 50642
   bgp router-id 195.191.198.1
   neighbor 188.209.98.245 remote-as 6910
   neighbor 188.209.98.245 interface eth2.625
   neighbor 188.209.98.245 update-source eth0.625
   neighbor 188.209.98.249 remote-as 6910
   neighbor 188.209.98.249 interface eth2.626
   neighbor 188.209.98.249 update-source eth0.626
   redistribute kernel
!
   address-family ipv4
   neighbor 188.209.98.245 activate
   neighbor 188.209.98.245 soft-reconfiguration inbound
   neighbor 188.209.98.245 route-map national-in in
   neighbor 188.209.98.245 route-map national-out out
   neighbor 188.209.98.249 activate
   neighbor 188.209.98.249 soft-reconfiguration inbound
   neighbor 188.209.98.249 route-map global-in in
   neighbor 188.209.98.249 route-map global-out out
   network 195.191.198.0/23
   network 94.176.130.0/23
   exit-address-family
!
access-list all permit any
access-list all-d deny any
access-list drop deny any
access-list net permit 195.191.198.0/23
access-list net permit 94.176.130.0/23
!
route-map national-in permit 10
      match ip address all
      set metric +0

!
route-map national-out permit 10
match ip address all
      set metric +0
!
route-map global-in permit 10
match ip address all
      set metric +0
!
route-map global-out permit 10
match ip address all
      set metric +0
!
line vty
!


and this is my zebra.conf:
!
! Zebra configuration saved from vty
!   2010/01/22 20:29:21
!
hostname Zebra
password xxxxxxxxxxx
enable password xxxxxxxxxxxx
log file /var/log/zebra.log
service password-encryption
!
interface eth0
!
interface eth1
!
interface eth2
!
interface lo
!
interface eth2.625
!
interface eth2.626
!
ip forwarding
!
line vty
!
this is getting me nuts, i realy don`t know what to do.


On 10/27/2011 03:02 PM, Ingo Flaschberger wrote:
> Dear Iulian,
>
>
>> I made the modification as you say but the routes still not get to 
>> kernel.
>> I think the bgpd part is ok becouse the prefixes get to bgpd but 
>> zebra does not recognize them.
>> Is there a way to debug zebra to see some errors becouse in 
>> /var/log/quagga/zebra.log it say only that is started , no other errors.
>
> Have you cleared the bgp-sessions after modfying the route-map?
> check:
> show ip bgp summary
> show ip route
> show ip bgp neighbors 10.10.10.10 received-routes
> show ip bgp neighbors 10.10.10.10 routes
>
> bye,
>     Ingo


More information about the Quagga-users mailing list