[quagga-users 12481] Re: quagga ospf and lxc virtualisation

Adrian Terranova aterranova at gmail.com
Sun Sep 18 22:29:29 IST 2011


Hi Vince,

Any shot there is some kind of physical discontinuity (or multicast
problem) in the lxc container or host kernel? Can you please include
the kernel / lxc versions and I'll try to spin them up? (Does unicast
stay working thruout? )

--Adrian

On Sun, Sep 18, 2011 at 9:46 AM,  <clownix at clownix.net> wrote:
> Hello,
> I have 2 exactly identical topologies running ospf: one based on uml
> virtual machines and one based on lxc virtual machines.
>
> The 2 topologies are available at clownix.net.
>
> My problem is that the lxc based demo does not work well, it stays stable
> only for moments before reloading LS.
>
> I have a message that does not exist in the uml demo, it is probably the
> cause of loss of hellos:
>
>  V3 Membership Report / Leave group 224.0.0.6 / Leave group 224
>
> What could cause ospf to leave the multicast group now and again?
>
> Note that I had previously another problem only for lxc:
> to have a command traceroute that worked, I had to do:
> echo 0 > /proc/sys/net/ipv4/icmp_ratemask in all my lxc machines.
>
> This is because in lxc the rate counter sum all values of all virtual
> machine lxc, only one host kernel being used for all machines.
>
> Is there some sort of rate counter for multicast messages?
> Thanks for your help.
> Vincent
>
>
> _______________________________________________
> Quagga-users mailing list
> Quagga-users at lists.quagga.net
> http://lists.quagga.net/mailman/listinfo/quagga-users
>


More information about the Quagga-users mailing list