[quagga-users 12940] two views as peers

Igor Belikov ivb at is.ua
Tue Jul 24 08:40:48 BST 2012


Hello Quagga-users,

  I'm using quagga 0.99.20-r1 from Gentoo portage.

  I have configuration with 2 bgp views:

bgp multiple-instance
!
router bgp 35714 view Infoservice
 bgp router-id 194.79.8.9
 network 31.128.96.0/19
 network 194.79.8.0/22
 [about 10 peers skipped]
 neighbor 194.79.9.254 remote-as 35714
 neighbor 194.79.9.254 description RS Triangle
 neighbor 194.79.9.254 update-source 194.79.9.130
 neighbor 194.79.9.254 soft-reconfiguration inbound
 neighbor 194.79.9.254 prefix-list q3pl-Triangle in
 neighbor 194.79.9.254 route-map map-local-preference-Triangle in
 neighbor 194.79.9.254 route-map map-IS-Triangle out
!
router bgp 35714 view Triangle
 bgp router-id 194.79.9.254
 neighbor 194.79.9.130 remote-as 35714
 neighbor 194.79.9.130 description RS Infoservice
 neighbor 194.79.9.130 update-source 194.79.9.254
 neighbor 194.79.9.130 soft-reconfiguration inbound
 neighbor 194.79.9.130 prefix-list q3pl-Infoservice in
 [some peers skipped]

  Both addresses - 194.79.9.130/25 and 194.79.9.254/25 - are exists on
  the same vlan.

  1st view (Infoservice) collects announces from different peers and
  sends resulting routing table on the border switch.

  2nd view (Triangle) share announces between some peers, build own
  routing table (from all peers) and announce resulting table to 1st
  view.

  This scheme works fine.

  But there is one problem.

  When I begun some experiments with configuration - deleting peer
  194.79.9.130 from view Triangle and try to create _with the same
  configuration_ - I got error message:

Can not configure the local system as neighbor

  I understand the sence of this error - quagga don't allow me to
  configure different peers on the same server. But I don't understand
  - why? The above scheme works fine without errors. So why I can't
  use this scheme?

  I was need to delete vlan with 194.79.9.130/25 and 194.79.9.254/25,
  restore configuration, and than recreate deleted vlan.

  I compile last quagga (0.99.21) from sources on different server to
  make patch to turn off check for peers on same interface. But I
  can't reproduce error. Views and peers were created without errors.
  But check still present in code.

  So I have some asks:

  1. To developers: please, add option in 'configure' to exclude from
  code check for several peers on th same interface.

  2. To all: please, help me to reproduce error message.

-- 
Best regards,
 Igor                          mailto:ivb at is.ua



More information about the Quagga-users mailing list