[quagga-users 12983] Re: Dynamically changing route-maps

Sami Halabi sodynet1 at gmail.com
Wed Oct 10 12:07:05 BST 2012


another thing is that I don't see where do you apply the route-maps so i
doubt this work...

On Wed, Oct 10, 2012 at 1:05 PM, Sami Halabi <sodynet1 at gmail.com> wrote:

> Hi,
> I use it with bgp, since i don't have a working ospf instance now, i'll
> give you how its done with bgp, with ospf should be similar:
> all these are soft reconfigure:
> clear ip bgp <neighbour_ip> in
> clear ip bgp <neighbour_ip> out
> clear ip bgp <neighbour_ip> soft
> -- the last one does in & out
>
> maybe some ospf user can help here?
>
> Sami
>
>
> On Wed, Oct 10, 2012 at 11:25 AM, Justin Cattle <j at ocado.com> wrote:
>
>> Hi Sami,
>>
>>
>> Thanks for the response.
>>
>> I am able to apply the route-map in vtysh, using config terminal mode.
>> However, I don't know how you perform soft updates.  Please give me a few
>> examples if you can :)
>>
>>
>>
>> The basic start config is similar to this:
>>
>> ### zebra.conf ###
>>
>> route-map RM_SET_SRC_0 permit 20
>>  set src 192.168.11.11
>>  ip protocol ospf route-map RM_SET_SRC_0
>> !
>> route-map RM_SET_SRC_1 permit 10
>>  set src 192.168.11.12
>> ! ip protocol ospf route-map RM_SET_SRC_1
>> !
>> interface dummy0
>>  ipv6 nd suppress-ra
>> !
>> interface dummy1
>>  ipv6 nd suppress-ra
>> !
>> interface eth0
>>  ipv6 nd suppress-ra
>> !
>> interface eth1
>>  ipv6 nd suppress-ra
>> !
>> interface eth2
>>  ipv6 nd suppress-ra
>> !
>> interface lo
>> !
>> line vty
>> !
>>
>>
>> ### ospfd.conf ###
>>
>>  !
>> interface dummy0
>>  ip ospf cost 10000
>>  ip ospf hello-interval 1
>>  ip ospf dead-interval 4
>>  ip ospf network point-to-point
>> !
>> interface dummy1
>>  ip ospf cost 10000
>>  ip ospf hello-interval 1
>>  ip ospf dead-interval 4
>>  ip ospf network point-to-point
>> !
>> interface eth0
>>  ip ospf cost 10000
>>  ip ospf hello-interval 1
>>  ip ospf dead-interval 4
>>  ip ospf network point-to-point
>> !
>> interface eth1
>>  ip ospf cost 10000
>>  ip ospf hello-interval 1
>>  ip ospf dead-interval 4
>>  ip ospf network point-to-point
>> !
>> interface eth2
>>  ip ospf cost 10000
>>  ip ospf hello-interval 1
>>  ip ospf dead-interval 4
>>  ip ospf network point-to-point
>> !
>> router ospf
>>  router-id 192.168.11.11
>>  log-adjacency-changes
>>  passive-interface default
>>  no passive-interface eth0
>>  no passive-interface eth2
>>  network 10.4.4.10/30 area 0.0.0.0
>>  network 10.4.4.14/30 area 0.0.0.0
>>  network 192.168.11.11/32 area 0.0.0.0
>>  network 192.168.11.12/32 area 0.0.0.0
>> !
>>
>>
>>
>>
>>
>> Cheers,
>> Just
>>
>>
>>
>> On 10 October 2012 06:30, Sami Halabi <sodynet1 at gmail.com> wrote:
>>
>>> Hi,
>>>
>>> To understand you better, supply the config please.
>>>
>>> the way would be to use vtysh with commands to do the route-map and
>>> clear with soft updates (inbound/outbound)
>>>
>>> Sami
>>>
>>> On Tue, Oct 9, 2012 at 10:47 PM, Justin Cattle <j at ocado.com> wrote:
>>>
>>>> Hi,
>>>>
>>>>
>>>> I've recently set-up a solution using quagga and ospf on linux (debian
>>>> squeeze) in an effort move away from a number of L2 issues.
>>>>
>>>> One of the things I'm using it to do is move "service loopback" address
>>>> from host to host.  I have the IPs configured on dummy interfaces, and
>>>> simply up/down the interfaces on different hosts to start advertising the
>>>> route to the IP in various places.  It works well.
>>>> I'm also setting the src ip of all the zebra maintained routes using a
>>>> route-map, this also works well.
>>>>
>>>> However, I would like to be able to have two different route-maps
>>>> defined (with different source ip addresses) and switch between the two,
>>>> thus changing the source address of traffic via the various different
>>>> routes.
>>>> I can make the other route map active, but I haven't yet found a way of
>>>> getting zebra to re-asses the routes with the new route-map.
>>>> I can restart the quagga daemons with the config files updated, but if
>>>> I do that I loose all the routes for a short time, which is longer than
>>>> desirable, plus it involves extra config file management.
>>>>
>>>>
>>>> Can anyone think of a way to make zebra re-parse all the ospf routes
>>>> once I've added the new route-map?
>>>> Or any alternate suggestions that may point me in the right direction?
>>>>
>>>> Thanks in advance!
>>>>
>>>>
>>>>
>>>> Cheers,
>>>> Just
>>>>
>>>>  This message has been checked for all known viruses by the Postini Virus Control Centre.
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> Quagga-users mailing list
>>>> Quagga-users at lists.quagga.net
>>>> http://lists.quagga.net/mailman/listinfo/quagga-users
>>>>
>>>>
>>>
>>>
>>> --
>>> Sami Halabi
>>> Information Systems Engineer
>>> NMS Projects Expert
>>> FreeBSD SysAdmin Expert
>>>
>>>
>> This message has been checked for all known viruses by the Postini Virus Control Centre.
>>
>>
>>
>
>
> --
> Sami Halabi
> Information Systems Engineer
> NMS Projects Expert
> FreeBSD SysAdmin Expert
>
>


-- 
Sami Halabi
Information Systems Engineer
NMS Projects Expert
FreeBSD SysAdmin Expert
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20121010/acfcf45c/attachment.html>


More information about the Quagga-users mailing list