[quagga-users 12998] Re: Quagga-users Digest, Vol 111, Issue 9

Akhil Nair/TVM/TCS akhil.nair at tcs.com
Fri Oct 19 14:16:57 BST 2012


replying to my earlier mail.
I made same setup, In which I am showing tcpdump output for various machine on various interface.
I am also attaching my configuration files of all the machines.

For Vm1 zebra.conf
!
! Zebra configuration saved from vty
!   2012/10/18 18:37:15
!
hostname Router
password zebra
enable password zebra
!
interface eth1
 ip address 192.168.3.0/24
 ipv6 nd suppress-ra
!
interface lo
!
interface rename2
 ip address 192.168.2.0/24
 ipv6 nd suppress-ra
!
ip route 192.168.3.0/24 eth1
!
ip forwarding
!
!
line vty
!

For Vm1 ospfd.conf :

!
! Zebra configuration saved from vty
!   2012/10/18 10:10:44
!
hostname ospfd
password zebra
banner motd file /usr/local/etc/quagga/motd
!
!
!
interface eth1
!
interface lo
!
interface rename2
!
router ospf
 ospf router-id 192.168.3.1
 redistribute connected
 redistribute static
 passive-interface rename2
 network 192.168.2.0/24 area 0.0.0.0
 network 192.168.3.0/24 area 0.0.0.0
 neighbor 192.168.3.2
!
line vty
!

For Vm2 zebra.conf

!
! Zebra configuration saved from vty
!   2012/10/17 15:34:18
!
hostname Router
password zebra
enable password zebra
!
interface eth1
 ip address 192.168.4.0/24
 ipv6 nd suppress-ra
!
interface lo
!
interface rename2
 ip address 192.168.3.0/24
 ipv6 nd suppress-ra
!
ip route 192.168.3.0/24 rename2
ip route 192.168.4.0/24 eth1
!
ip forwarding
!
!
line vty
!

For Vm2 ospfd.conf :

!
! Zebra configuration saved from vty
!   2012/10/18 10:08:31
!
hostname ospfd
password zebra
log stdout
!
!
!
interface eth1
!
interface lo
!
interface rename2
!
router ospf
 ospf router-id 192.168.4.1
 redistribute connected
 redistribute static
 network 192.168.3.0/24 area 0.0.0.0
 network 192.168.4.0/24 area 0.0.0.0
 neighbor 192.168.4.2
 neighbor 192.168.3.1
!
line vty
!
For Vm3 zebra.conf

!
! Zebra configuration saved from vty
!   2012/10/11 16:08:40
!
hostname Router
password zebra
enable password zebra
!
interface eth1
 ip address 192.168.5.0/24
 ipv6 nd suppress-ra
!
interface lo
!
interface rename2
 ip address 192.168.4.0/24
 ipv6 nd suppress-ra
!
ip route 192.168.4.0/24 rename2
!
ip forwarding
!
!
line vty
!

For Vm3 ospfd.conf

!
! Zebra configuration saved from vty
!   2012/10/19 11:34:37
!
hostname ospfd
password zebra
log stdout
!
!
!
interface eth1
!
interface lo
!
interface rename2
!
router ospf
 ospf router-id 192.168.4.2
 redistribute connected
 redistribute static
 passive-interface eth1
 network 192.168.4.0/24 area 0.0.0.0
 network 192.168.5.0/24 area 0.0.0.0
 neighbor 192.168.4.1
!
line vty
!

The below logs are without adding static routes.The status of adjacency is Exstart in all three machines.With this configuration I am not able to see routes via command "show ip ospf route"

For Vm1's eth1 interface tcpdump output

17:35:43.598479 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:35:47.580204 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:35:53.598756 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:35:57.581161 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:03.599094 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:07.581437 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:13.599234 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:17.582411 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:23.599479 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:27.583324 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:33.599697 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:37.583725 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:43.599998 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:47.584446 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:53.600210 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:57.585394 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:03.600455 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:07.585675 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:13.600692 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:17.586630 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:23.600931 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:27.587354 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:33.601130 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48


For Vm1's rename2 interface tcpdump output

17:44:08.198704 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:14.246913 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:18.199279 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:24.208132 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:28.199791 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:34.247919 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:38.200129 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:44.209282 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:48.200906 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:54.248885 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:58.201228 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:04.210433 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:08.201461 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:14.262130 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:18.202010 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:24.211998 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:28.202455 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:34.251889 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:38.202823 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:44.213215 IP 192.168.3.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:45:48.203119 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48



For Vm2's eth1 interface tcpdump output

17:36:35.939922 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:38.171962 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:45.900740 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:48.172845 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:55.901164 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:36:58.173672 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:05.901539 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:08.173995 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:15.940917 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:18.174860 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:25.902237 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:28.175655 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:35.942130 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:38.176013 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:45.902866 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:48.176875 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:55.942914 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:37:58.177682 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:38:05.903528 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:38:08.178006 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
17:38:15.942896 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
17:38:18.178849 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48


For Vm3's rename2 interface tcpdump output

17:42:15.602201 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:42:17.887177 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:42:25.602309 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:42:27.887777 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:42:35.602442 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:42:37.887955 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:42:45.602528 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:42:47.888610 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:42:55.602666 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:42:57.889468 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:05.603728 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:07.889881 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:15.603996 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:17.890388 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:25.605064 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:27.890889 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:35.606129 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:37.891182 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:45.606410 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:47.891780 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:55.607436 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48
17:43:57.892404 IP 192.168.4.1 > 224.0.0.5: OSPFv2, Hello, length 48
17:44:05.608459 IP t3 > 224.0.0.5: OSPFv2, Hello, length 48


After this I added static route to immediate adjacent neighbor.By this I got Full state adjacency.I also got routes in quagga by command "show ip ospf route".But nothing got reflected in "ip ro" command.The following are the logs :

For Vm1's eth1 interface tcpdump output

18:03:23.675120 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
18:03:27.669483 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:03:33.675487 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
18:03:37.670512 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:03:43.676274 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
18:03:47.710153 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:03:53.676976 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
18:03:57.671178 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:03.677393 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:07.671638 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:13.678262 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:17.672539 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:17.672570 IP 192.168.3.2 > 224.0.0.5: OSPFv2, LS-Update, length 60
18:04:17.857022 IP t1 > 224.0.0.5: OSPFv2, LS-Ack, length 44
18:04:23.679060 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:27.672718 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:33.679414 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:37.673092 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:43.679893 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:47.673669 IP 192.168.3.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:04:53.680443 IP t1 > 224.0.0.5: OSPFv2, Hello, length 48

For Vm2's eth1 interface tcpdump output

18:12:36.044887 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:12:38.277765 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
18:12:46.006373 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:12:48.277888 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
18:12:56.045896 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:12:58.278051 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:06.007576 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:08.278167 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:16.047124 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:18.278317 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:26.008656 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:28.279414 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:36.049083 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:38.279816 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:46.009410 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:48.280899 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:56.048873 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:13:58.281986 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48
18:14:06.010591 IP 192.168.4.2 > 224.0.0.5: OSPFv2, Hello, length 48
18:14:08.282352 IP t2 > 224.0.0.5: OSPFv2, Hello, length 48


For Vm2's rename2 interface tcpdump output

 

For Vm3's rename2 interface tcpdump output
=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you





More information about the Quagga-users mailing list