[quagga-users 13446] Re: isisd configuration

Gabriela Botea gabriela.botea at gmail.com
Fri Sep 13 14:40:40 BST 2013


Hi Sasa,

What do you mean by cannot ping those interfaces?
Please read here [1] about the IS-IS adjacency and link-state databases.


[1]
http://www.cisco.com/en/US/products/ps6599/products_white_paper09186a00800a3e6f.shtml#wp38952

On Tue, Sep 10, 2013 at 1:18 PM, Sasa Takov <sasatakov at gmail.com> wrote:

>
> Hi to all!
>
> I have configured isis daemon, but it doesn't work properly. I have 5
> routers. When I place all routers in one area everything work good, but
> when place 3 router in one area and others routers in another area, I have
> problem.
> Image of network is in atachment.
> R1 ping interfaces 2.2., 3.1 and 3.2, but can't ping 4.1, 4.2 and 5.1.
> R2 ping all interfaces except 4.2 and 5.1.
> R3 ping all interfaces.
> R4 ping all interfaces except 2.1 and 1.1.
> R5 ping 4.1., 3.2 and of course 5.1 and 4.2.
>
> Here are configurations of isisd.conf files:
>
> R1
> hostname isisd1
> password foo
> enable password foo
> log stdout
> !
> interface eth1
> ip router isis test1
> isis circuit-type level-1
> !
> router isis test1
> net 49.0001.1921.6810.0001
> is-type level-1
> !
>
>
> R2
> hostname isisd2
> password foo
> enable password foo
> log stdout
> !
> interface eth1
> ip router isis test1
> isis circuit-type level-1
> !
> interface eth2
> ip router isis test1
> isis circuit-type level-1
> !
> router isis test1
> net 49.0001.1921.6810.0002
> is-type level-1
> !
>
> R3
> hostname isisd3
> password foo
> enable password foo
> log stdout
> !
> interface eth1
> ip router isis test1
> isis circuit-type level-1
> !
> interface eth2
> ip router isis test1
> isis circuit-type level-2-only
> !
> router isis test1
> net 49.0001.1921.6810.0003
> is-type level-1-2
> !
>
> R4
> hostname isisd4
> password foo
> enable password foo
> log stdout
> !
> interface eth2
> ip router isis test2
> isis circuit-type level-1
> !
> interface eth1
> ip router isis test2
> isis circuit-type level-2-only
> !
> router isis test2
> net 49.0002.1921.6810.0004
> is-type level-1-2
>
> R5
> hostname isisd5
> password foo
> enable password foo
> log stdout
> !
> interface eth1
> ip router isis test2
>

you have no test 2 set


> isis circuit-type level-1
> !
> router isis test1
> net 49.0002.1921.6810.0005
> is-type level-1
> !
>
>
> Does anybody know what I should add in configuration to solve this problem.
>
> Thanks in advance.
>
> _______________________________________________
> Quagga-users mailing list
> Quagga-users at lists.quagga.net
> http://lists.quagga.net/mailman/listinfo/quagga-users
>
>


-- 
Regards,

*Gabriela Botea*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20130913/06a33610/attachment.html>


More information about the Quagga-users mailing list