[quagga-users 13890] Re: OSPF Metric for Loopback?

Jiann-Ming Su su_js1 at yahoo.com
Wed Jan 21 07:07:30 GMT 2015


Thanks for the response.  That's how we have ospfd configured.  However, the ospf cost on lo:0 is not added to the metric.  Only the ospf cost of the peering router gets added to the metric.  FWIW, our ospf area is nssa.


router ospf
 ospf router-id 10.248.6.4
 passive-interface lo
 passive-interface lo:0
 passive-interface lo:1
 network 10.248.6.0/29 area 1.18.1.1
 network 192.168.20.12/32 area 1.18.1.1
 network 192.168.20.13/32 area 1.18.1.1
 area 1.18.1.1 nssa translate-never


On Tuesday, January 20, 2015 10:53 PM, Lu Feng <lu.feng at 6wind.com> wrote:


>
>
>Hi,
>
>I suggest not to use the redistribution. The following is a simple way to
>achieve what you want (suppose address A.B.C.D/M is configured on lo:0):
>
>interface lo:0
>ip ospf cost 100
>
>router ospf
>network A.B.C.D/M area N     <== let OSPF run on lo:0
>passive-interface lo:0             <== let OSPF drop all packets on lo:0
><...your other configurations...>
>
>Hope this helpful.
>
>Best regards,
>Feng Lu
>
>
>On 1/17/15, Jiann-Ming Su <su_js1 at yahoo.com> wrote:
>> How should quagga/ospfd be configured such that the ip ospf cost configured
>> for a loopback is added to the metric cost when the host route gets
>> redistributed?
>> Sample ospfd config:
>> interface lo:0
>>  ip ospf cost 100
>> The router that the quagga server peers with has ip ospf cost 500.  The
>> metric for the anycast associated with lo:0 shows the 500 added, but not the
>> additional 100 listed in the ospfd config.  Thanks for any tips.
>>
>>
>
>
>



More information about the Quagga-users mailing list