[quagga-users 13894] Re: Route-map not found with OSPF6

Daniel STICKNEY dstickney at optilian.com
Thu Jan 22 10:06:05 GMT 2015


Hello Alexis,

Thanks for your suggestion. Here is the current structure of the saved
config file.
_____________________________________
log file /var/log/quagga/Quagga.log
!
interfaces
!
router bgp
!
router ospf
!
router ospf6
 router-id
 redistribute kernel route-map OPT-OSPF6-RDIST
 redistribute connected route-map OPT-OSPF6-RDIST
 redistribute static route-map OPT-OSPF6-RDIST
 interface
!
ip routes
ipv6 routes
!
ip prefix-lists
ipv6 prefix-lists
!
ip as-path access-list
!
route-map OPT-OSPF6-RDIST
!
ip forwarding
ipv6 forwarding
!
line vty
_____________________________________


Reading from top to bottom I see the route-map created after the
configuration of ospf6. I imagine that is the expected (and "correct")
order?

Thanks for your time,
Daniel


Le 21/01/2015 17:32, Alexis Rosen a écrit :
> Check your saved config file (not the in-memory config) and see if the route map is created before or after ospf6 is configured. I vaguely recall a bug where quagga was saving them in the wrong order. That would explain what you're seeing.
>
> /a
>
> On Jan 21, 2015, at 11:03 AM, Daniel STICKNEY <dstickney at optilian.com> wrote:
>> Starting from a functioning base configuration (OSPF6 working with no
>> redistribution), here is how I reproduced the problem :
>>
>> conf t
>> ipv6 prefix-list PL_OPTLN6 seq 20 permit 2a00:18a8:400::/62
>> ipv6 prefix-list PL_OPTLN6 seq 100 deny any
>> route-map OPT-OSPF6-RDIST permit 10
>>  match  ipv6  address  prefix-list  PL_OPTLN6
>>  exit
>> router ospf6
>>  redistribute  connected  route-map  OPT-OSPF6-RDIST
>>  redistribute  kernel  route-map  OPT-OSPF6-RDIST
>>  redistribute  static  route-map  OPT-OSPF6-RDIST
>>  exit
>> ipv6  route  2a00:18a8:400::/62 lo
>> exit
>> wr mem
>>
>> At this point the redistribution of this static route works, and I see
>> the static route in the routing tables of the other OSPF6 routers on the
>> network.
>>
>> I then restart Quagga
>> /etc/init.d/quagga restart
>>
>> I then see this message in Quagga.log
>> 2015/01/21 16:30:32 OSPF6: route-map "OPT-OSPF6-RDIST" not found,
>> suppress redistributing
>>
>> OSPF6d establishes adjacencies with the other OSPF6 routers but
>> redistributes nothing, as expected after seeing this log message.
>>
>> I've tried different route-map names, such as RDIST, with no special
>> characters, and I get the exact same results.
>>
>> To check that OSPF6d can see the route-map I connect to OSPF6d via
>> telnet and execute the following command, which confirms that the
>> route-map does exist and is seen by OSPF6d.
>>
>> # show route-map OPT-OSPF6-RDIST
>> OSPF6:
>> route-map OPT-OSPF6-RDIST, permit, sequence 10
>>  Match clauses:
>>    ipv6 address prefix-list PL_OPTLN6
>>  Set clauses:
>>  Call clause:
>>  Action:
>>    Exit routemap


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20150122/51f8ac35/attachment.sig>


More information about the Quagga-users mailing list