[quagga-users 14149] default routes from BGP & nothing in kernel routing table

Christopher J. Umina chris+quagga at uminac.com
Thu Oct 1 18:38:59 BST 2015


Hello everybody,

I'm running a very basic configuration on my internal network with some
anycast DNS servers. On each server, I run FreeBSD and quagga. The server
lives in a /29 with two upstream Cisco L3 switches. From each L3 switch the
server receives a default route only. This all works as expected.

The problem is that although the BGP sessions come up and the routes are in
the BGP routing table on the server, a default route is never injected into
the server's kernel routing table.

Have I missed some configuration here, or is this a bug?

Some information:

# show version
Quagga 0.99.24.1 ().
Copyright 1996-2005 Kunihiro Ishiguro, et al.
configured with:
    --enable-user=quagga --enable-group=quagga
--sysconfdir=/usr/local/etc/quagga --localstatedir=/var/run/quagga
--enable-vtysh --disable-irdb --enable-isisd --disable-isis-topology
--enable-bgp-announce --enable-opaque-lsa --without-libpam --enable-pimd
--enable-rtadv --disable-snmp --disable-tcp-zebra --prefix=/usr/local
--mandir=/usr/local/man --infodir=/usr/local/info/
--build=amd64-portbld-freebsd10.1
# show run
Building configuration...

Current configuration:
!
log syslog
!
interface em0
 ipv6 nd suppress-ra
 no link-detect
!
interface lo0
 no link-detect
!
router bgp 64625
 bgp router-id 10.0.20.142
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 network 10.1.1.0/32
 network 10.1.2.0/32
 neighbor 10.0.20.138 remote-as 64624
 neighbor 10.0.20.138 description 'csw01.wkf01'
 neighbor 10.0.20.138 activate
 neighbor 10.0.20.139 remote-as 64624
 neighbor 10.0.20.139 description 'csw02.wkf01'
 neighbor 10.0.20.139 activate
!
line vty
!
end
# show ip bgp
BGP table version is 0, local router ID is 10.0.20.142
Status codes: s suppressed, d damped, h history, * valid, > best, =
multipath,
              i internal, r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  0.0.0.0          10.0.20.138                            0 64624 i
*>                  10.0.20.139                            0 64624 i
*> 10.1.1.0/32
                    0.0.0.0                  0         32768 i
*> 10.1.2.0/32
                    0.0.0.0                  0         32768 i
# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP,
       O - OSPF, I - IS-IS, B - BGP, P - PIM, A - Babel,
       > - selected route, * - FIB route

C>* 10.0.20.136/29 is directly connected, em0
C>* 10.1.1.0/32 is directly connected, lo0
C>* 10.1.2.0/32 is directly connected, lo0
C>* 127.0.0.0/8 is directly connected, lo0
# exit
# uname -or
FreeBSD 10.2-RELEASE

Thank you!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20151001/23a65da3/attachment.html>


More information about the Quagga-users mailing list