[quagga-users 14369] What would cause IS-IS routes to not be added to the FIB?

Travis Pressler travis.pressler at scientiallc.com
Tue Jul 26 22:15:05 BST 2016


I'm attempting to set up very basic communication using the IS-IS protocol provided by Quagga version v1.0

I've got `Host A` with an interface `enp0` that has address `10.0.1.50/24`.           
I've got another host `Host B` with an interface `enp1` that has address `10.1.1.25/24`.  
These interfaces are directly connected by cable.

This is my current `isisd.conf` file:


    hostname HostA
    password ***
    enable password ***
    log stdout

    interface enp0
    ip router isis HOSTA
    ipv6 router isis HOSTA
    isis network point-to-point
    isis hello-interval 5

And this is my `zebra.conf:`

    hostname HostA
    password ***
    enable password ***

These files for Host B are the same but with `HostA` replaced with `HostB`.

When I run `show isis neighbor` on Host A I can see Host B; Host B can also see Host A in its list of neighbors

    HostA            enp0    1  Up           48       2020.2020.2020

When I run `show ip route`, I can see IS-IS routes from Host A to Host B, but they are inactive and they are not FIB routes.

    I   10.1.1.0/24 [115/20] via 10.1.1.25 inactive, 00:47:31

>From what I understand, this may occur due to there being a better alternate route, but I see no other path to this destination in the list of routes.

Why is this route not active nor a FIB route? Also, is there any IS-IS-specific Quagga documentation?

Best Regards,
Travis Pressler



More information about the Quagga-users mailing list