[quagga-users 14424] how to configure and ping and connect two BGP ubuntu in GNS3?

Prince Martin tesleft at hotmail.com
Fri Sep 2 10:16:52 BST 2016


i connect ethernet of two ubuntu each other which act as BGP router in GNS3


but eth0 can not be brought up and ping each other


sh ip bgp summary


can show neighbor is 192.168.2.3 in ubuntu 192.168.1.2


but can not ping in ubuntu , how to verify two BGP network connected?


martin at martin:~$ sudo ifup eth0
RTNETLINK answers: File exists
Failed to bring up eth0.


ubuntu1
martin at martin:~$ sudo cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.1.2
gateway 192.168.2.3
netmask 255.255.255.0
dns-nameservers 8.8.8.8

ubuntu1
bgpd.conf

!bgp mulitple-instance
!
router bgp 7675
 bgp router-id 192.168.1.2
 network 192.168.2.0/24
 neighbor 192.168.2.3 remote-as 7676
 neighbor 192.168.2.3 route-map set-nexthop out
 neighbor 192.168.2.3 ebgp-multihop
! neighbor 10.0.0.2 next-hop-self
!
! access-list all permit any
!
route-map set-nexthop permit 10
 match ip address all
 set ip next-hop 192.168.2.3




ubuntu2
bgpd.conf

!bgp mulitple-instance
!
router bgp 7676
 bgp router-id 192.168.2.3
 network 192.168.1.0/24
 neighbor 192.168.1.2 remote-as 7675
 neighbor 192.168.1.2 route-map set-nexthop out
 neighbor 192.168.1.2 ebgp-multihop
! neighbor 192.168.1.2 next-hop-self
!
! access-list all permit any
!
route-map set-nexthop permit 10
 match ip address all
 set ip next-hop 192.168.1.2

ubuntu2
/etc/network/interfaces

auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.2.3
gateway 192.168.1.2
netmask 255.255.255.0
dns-nameservers 8.8.8.8




Regards,
Martin

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20160902/41f43508/attachment.html>


More information about the Quagga-users mailing list