[quagga-users 14429] set ip not applied

Alarig Le Lay alarig at swordarmor.fr
Mon Sep 12 21:24:51 BST 2016


Hi,

My main aim is to advertise a different next-hop in an OSPF setup. I
tried to use a route-map to achieve that, but my set ip command is not
applied (at last, I don’t see it in the running-config)

judicael# configure terminal 
judicael(config)# route-map PUBLIC-NEXT-HOP permit 1
judicael(config-route-map)# match ip address all
judicael(config-route-map)# set ip next-hop 89.234.186.3
judicael(config-route-map)# end
judicael# show running-config 
Building configuration...

Current configuration:
! […]
router ospf
 ospf router-id 89.234.186.3
 redistribute kernel
 redistribute connected
 redistribute static
 passive-interface eth0
 passive-interface eth1
 passive-interface ppp0
 passive-interface tun-tcp0
 passive-interface tun-udp0
 network 89.234.186.0/24 area 0.0.0.0
 network 172.16.0.0/24 area 0.0.0.0
 area 0.0.0.0 range 89.234.186.0/24
!
route-map PUBLIC-NEXT-HOP permit 1
 match ip address all
!
! […]

I tried to apply the distribute-list anyway, but nothing append.
judicael# configure terminal 
judicael(config)# router ospf
judicael(config-router)# distribute-list PUBLIC-NEXT-HOP out kernel
judicael(config-router)# 

bird> show ospf neighbors 
ospf1:
Router ID       Pri          State      DTime   Interface  Router IP   
89.234.186.193    1     Full/DR         00:34   em2.41     172.16.0.10    
89.234.186.3     90     Full/Other      00:33   em2.41     172.16.0.6    

Obviously, 89.234.186.3 is on the interface of the machine that I want
the traffic to come from.
root at judicael:~# ip addr show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether de:61:2c:0e:b9:bc brd ff:ff:ff:ff:ff:ff
    inet 89.234.186.3/25 brd 89.234.186.127 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 2a00:5884::3/48 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::dc61:2cff:fe0e:b9bc/64 scope link 
       valid_lft forever preferred_lft forever


I tried this on both fedora and debian, respectively on a
0.99.24.1-2.fc23.x86_64 and a 0.99.23.1-1+deb8u2.

-- 
alarig
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: Digital signature
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20160912/92284d30/attachment.sig>


More information about the Quagga-users mailing list