[quagga-users 14669] BGP redistribute into OSPF

jihua cai caijihua at gmail.com
Sun Apr 23 12:29:39 BST 2017


Hi,
I test the quagga 1.x,with the following configuration:

router bgp 65501
 no synchronization
 bgp router-id 172.16.0.3
 neighbor 172.16.0.1 remote-as 65501
 neighbor 172.16.0.1 update-source 172.16.0.3
 neighbor 172.16.0.1 advertisement-interval 1
 neighbor 172.16.0.1 next-hop-self
 neighbor 172.16.0.1 send-community all
 neighbor 172.16.0.2 remote-as 65501
 neighbor 172.16.0.2 update-source 172.16.0.3
 neighbor 172.16.0.2 advertisement-interval 1
 neighbor 172.16.0.2 next-hop-self
 neighbor 172.16.0.2 send-community all
 neighbor 172.16.0.4 remote-as 65501
 neighbor 172.16.0.4 update-source 172.16.0.3
 neighbor 172.16.0.4 advertisement-interval 1
 neighbor 172.16.0.4 next-hop-self
 neighbor 172.16.0.4 send-community all
 neighbor 172.16.1.14 remote-as 65502
 neighbor 172.16.1.14 ebgp-multihop 10
 neighbor 172.16.1.14 advertisement-interval 1
 neighbor 172.16.1.14 send-community all
 no auto-summary

router ospf
 redistribute bgp metric 100 metric-type 1
 passive-interface default
 no passive-interface qgg3-qgg1
 no passive-interface qgg3-qgg2
 network 172.16.0.0/24 area 0.0.0.0
 network 172.16.1.0/24 area 0.0.0.0

All BGP route is iBGP, and not in the FIB
show ip route bgp
Codes: K - kernel route, C - connected, S - static, R - RIP,
       O - OSPF, I - IS-IS, B - BGP, P - PIM, A - Babel, N - NHRP,
       > - selected route, * - FIB route

B   172.17.0.0/22 [200/0] via 172.16.0.4, 00:00:03
B   172.17.0.0/23 [200/0] via 172.16.0.4, 00:00:03
B   172.17.0.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.1.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.2.0/23 [200/0] via 172.16.0.4, 00:00:03
B   172.17.2.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.3.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.4.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.5.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.6.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.7.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.8.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.9.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.10.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.11.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.12.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.13.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.14.0/24 [200/0] via 172.16.0.4, 00:00:03
B   172.17.15.0/24 [200/0] via 172.16.0.4, 00:00:03

But these BGP route always redistributed into OSPF.
When i test the quagga 0.99.x, these BGP route not redistributed into OSPF.
Why is that?
Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20170423/4933c766/attachment.html>


More information about the Quagga-users mailing list