[quagga-users 14700] OSPF adjacency not happening on unnumbered interface

Vasco Matos vascom at swns.ch
Fri Jun 23 15:36:33 BST 2017


Hi all,

So I've been trying with no success to setup OSPF adjacency through
unnumbered interfaces on two hosts running quagga.


my setup is something similar to this


           lo1: 10.252.253.1/24      ----------- eth0               
eth0 -----------   lo1: 10.252.253.3/24
                                                   |    Host1   
|----------------- |   Host2       |
                                                   -----------       
                        -----------
                                            vti1
-----------------------------------------vt1  


Basically I want to assign the lo1 IP addr to the vti1 interface on both
routers. I need to do this because I need perform encryption through
Host1 and Host2 and that needs to be done through the vti1 interfaces
over eth0 connection.

According to my troubleshoot I'm able to see the multicast ospf HELLO
packets on both interfaces for both IPs (10.252.253.1 & 10.252.253.3) so
it seems that the negotiation is happening but seems that the HELLO
packets are simply ignored.
However, for instance if I assign a /31 subnet for the vti1 interfaces
the adjacency comes up instantly (with the same OSPF config, adding only
the announcement of the /31 network). My problem is that I will need to
create many of this tunnels and with the use of unnumbered IP interfaces
it would save me a lot of subnet spaces and would simplify my life a lot.

Quagga also identifies the interface vti1 as OSPF POINT-TO-POINT network
type by default

Anybody has a clue or already passed through this so can help me
figuring how to solve this issue ?

here is my actual config of interfaces+quagga:

--------------------------
Host1:

auto eth0
iface eth0 inet static
    address 10.2.20.81
    netmask 255.255.255.240


auto lo1
iface lo1 inet static
        address 10.252.253.1
        netmask 255.255.255.255
        pre-up ip link add name lo1 type dummy
        pre-up ip link set lo1 up
        down ip link del lo1

auto svti1
iface vti1 inet manual
 pre-up ip link add vti1 type vti local 10.2.20.81 remote 10.2.20.83 key
0x0000000A
 up ip addr add 10.252.253.1/32 dev svti1
 post-up ip link set dev vti1 mtu 1420; sysctl
net.ipv4.conf.svti1.disable_policy=1
 post-down ip link del vti1

vtysh -c "show run"
(...)
!
interface vti1
 ip ospf authentication message-digest
 ip ospf dead-interval 5
 ip ospf hello-interval 1
 ip ospf message-digest-key 1 md5 <password>
 ipv6 nd suppress-ra
 no link-detect
 multicast
(...)
!
router ospf
 ospf router-id 10.252.253.1
 passive-interface default
 no passive-interface vti1
 network 10.2.20.64/29 area 0.0.0.0
 network 10.255.255.1/32 area 0.0.0.0
 area 0.0.0.0 authentication message-digest
!

--------------------------
Host2:

auto eth0
iface eth0 inet static
    address 10.2.20.83
    netmask 255.255.255.240

auto lo1
iface lo1 inet static
        address 10.252.253.3
        netmask 255.255.255.255
        pre-up ip link add name lo1 type dummy
        pre-up ip link set lo1 up
        down ip link del lo1

auto svti1
iface svti1 inet manual
 pre-up ip link add svti1 type vti local 10.2.20.83 remote 10.2.20.81
key 0x0000000A
 up ip addr add 10.252.253.3/32 dev svti1
 post-up ip link set dev svti1 mtu 1420; sysctl
net.ipv4.conf.svti1.disable_policy=1
 post-down ip link del svti1


vtysh -c "show run"
(...)
!
interface vti1
 ip ospf authentication message-digest
 ip ospf dead-interval 5
 ip ospf hello-interval 1
 ip ospf message-digest-key 1 md5 <password>
 ipv6 nd suppress-ra
 multicast
 no link-detect
!
(...)
!
router ospf
 ospf router-id 10.252.253.3
 passive-interface default
 no passive-interface vti1
 network 10.2.20.64/29 area 0.0.0.0
 network 10.252.253.3/32 area 0.0.0.0
 area 0.0.0.0 authentication message-digest
!


I can provide more info if needed
Thank you

Vasco





More information about the Quagga-users mailing list