[quagga-users 14936] Re: Assertion failed in ospfd 1.2.3

Balaji Gurudoss balajig81 at gmail.com
Fri Feb 16 16:41:58 GMT 2018


Hi

This should suffice. Will investigate this and resolve this

Thanks
   Balaji

On Fri, 16 Feb 2018 at 22:04, Ivan Kuznetsov <kia at solvo.ru> wrote:

> Hello
>
> I try to setup a test software router under Linux (Oracle Linux 6
> x86_64) and Quagga 1.2.3. ospfd being started exited a few seconds after
> with assertion fault. It seems that is a time of first multicast network
> packet received. OSPF configuration is quite simple :
>
> interface eth0
> !
> interface eth0.3
>   ip ospf authentication-key ********
> !
> interface eth1
> !
> interface eth2
> !
> interface eth3
> !
> interface lo
> !
> router ospf
>   ospf router-id 172.16.83.71
>   auto-cost reference-bandwidth 1000
>   passive-interface eth0
>   passive-interface eth1
>   passive-interface eth2
>   passive-interface eth3
>   network 172.16.83.71/26 area 172.16.80.0
>   area 172.16.80.0 authentication
> !
> line vty
>
> Quagga 1.2.2 at the same computer and configuration works as desired.
>
> I built 1.2.3 RPM using quagga.spec file from tarball with only cosmetic
> changes. It is near identical against one from 1.2.2. Building
> environment is the same
>
> Here is crashlog:
>
> 2018/02/16 18:32:26 OSPF: Assertion `thread->master != ((void *)0) &&
> thread != ((void *)0)' failed in file thread.c, line 607, function
> thread_add_unuse
> 2018/02/16 18:32:26 OSPF: Backtrace for 12 stack frames:
> 2018/02/16 18:32:26 OSPF: [bt 0]
> /usr/lib64/quagga/libzebra.so.1(zlog_backtrace+0x35) [0x7fbfd7cb2ea5]
> 2018/02/16 18:32:26 OSPF: [bt 1]
> /usr/lib64/quagga/libzebra.so.1(_zlog_assert_failed+0x67) [0x7fbfd7cb3027]
> 2018/02/16 18:32:26 OSPF: [bt 2]
> /usr/lib64/quagga/libzebra.so.1(+0x27cfe) [0x7fbfd7ca1cfe]
> 2018/02/16 18:32:26 OSPF: [bt 3]
> /usr/lib64/quagga/libzebra.so.1(+0x28389) [0x7fbfd7ca2389]
> 2018/02/16 18:32:26 OSPF: [bt 4]
> /usr/lib64/quagga/libzebra.so.1(funcname_thread_execute+0x4c)
> [0x7fbfd7ca30cc]
> 2018/02/16 18:32:26 OSPF: [bt 5]
> /usr/lib64/quagga/libospf.so.0(+0x2f71d) [0x7fbfd7f1d71d]
> 2018/02/16 18:32:26 OSPF: [bt 6]
> /usr/lib64/quagga/libospf.so.0(ospf_read+0x149e) [0x7fbfd7f200be]
> 2018/02/16 18:32:26 OSPF: [bt 7]
> /usr/lib64/quagga/libzebra.so.1(+0x282b2) [0x7fbfd7ca22b2]
> 2018/02/16 18:32:26 OSPF: [bt 8]
> /usr/lib64/quagga/libzebra.so.1(thread_main+0x18) [0x7fbfd7ca3838]
> 2018/02/16 18:32:26 OSPF: [bt 9] ospfd(main+0x337) [0x401b07]
> 2018/02/16 18:32:26 OSPF: [bt 10]
> /lib64/libc.so.6(__libc_start_main+0xfd) [0x3d4f01ed1d]
> 2018/02/16 18:32:26 OSPF: [bt 11] ospfd() [0x401669]
> 2018/02/16 18:32:26 OSPF: Current thread not known/applicable
>
> What can be a troubleshooting procedure?
>
>
> Regards, Ivan Kuznetsov
> SOLVO ltd
>
> _______________________________________________
> Quagga-users mailing list
> Quagga-users at lists.quagga.net
> https://lists.quagga.net/mailman/listinfo/quagga-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quagga.net/pipermail/quagga-users/attachments/20180216/2122828e/attachment.html>


More information about the Quagga-users mailing list