<div dir="ltr">Hi,<div>Lately i see strange messages on my /var/log, i use FBSD-8.1-R with Quagga 0.99.17</div><div><div>Nov 26 19:28:50 bgpServer watchquagga[1394]: zebra state -&gt; unresponsive : no response yet to ping sent 10 seconds ago</div>
<div>Nov 26 19:28:57 bgpServer zebra[88251]: SLOW THREAD: task zebra_client_read (102aae0) ran for 21313ms (cpu time 1ms)</div><div>Nov 26 19:28:57 bgpServer watchquagga[1394]: zebra: slow echo response finally received after 16.449412 seconds</div>
<div>Nov 26 19:29:12 bgpServer watchquagga[1394]: zebra state -&gt; unresponsive : no response yet to ping sent 10 seconds ago</div><div>Nov 26 19:29:12 bgpServer watchquagga[1394]: bgpd state -&gt; unresponsive : no response yet to ping sent 10 seconds ago</div>
<div>Nov 26 19:29:15 bgpServer zebra[88251]: SLOW THREAD: task zebra_client_read (102aae0) ran for 17260ms (cpu time 0ms)</div><div>Nov 26 19:29:15 bgpServer watchquagga[1394]: zebra: slow echo response finally received after 13.707425 seconds</div>
<div>Nov 26 19:29:15 bgpServer bgpd[79850]: SLOW THREAD: task bgp_read (10675d0) ran for 17095ms (cpu time 5ms)</div><div>Nov 26 19:29:15 bgpServer watchquagga[1394]: bgpd: slow echo response finally received after 13.700411 seconds</div>
<div>Nov 26 19:29:30 bgpServer watchquagga[1394]: bgpd state -&gt; unresponsive : no response yet to ping sent 10 seconds ago</div><div>Nov 26 19:29:30 bgpServer watchquagga[1394]: zebra state -&gt; unresponsive : no response yet to ping sent 10 seconds ago</div>
<div>Nov 26 19:29:34 bgpServer bgpd[79850]: SLOW THREAD: task bgp_read (10675d0) ran for 16281ms (cpu time 0ms)</div><div>Nov 26 19:29:34 bgpServer zebra[88251]: SLOW THREAD: task zebra_client_read (102aae0) ran for 16276ms (cpu time 0ms)</div>
<div>Nov 26 19:29:34 bgpServer watchquagga[1394]: bgpd: slow echo response finally received after 13.585467 seconds</div><div>Nov 26 19:29:34 bgpServer watchquagga[1394]: zebra: slow echo response finally received after 13.496174 seconds</div>
<div>Nov 26 19:29:49 bgpServer watchquagga[1394]: bgpd state -&gt; unresponsive : no response yet to ping sent 10 seconds ago</div><div>Nov 26 19:29:49 bgpServer watchquagga[1394]: zebra state -&gt; unresponsive : no response yet to ping sent 10 seconds ago</div>
<div>Nov 26 19:29:54 bgpServer watchquagga[1394]: Forked background command [pid 79871]: /usr/local/etc/quagga/service bgpd stop</div><div>Nov 26 19:30:00 bgpServer watchquagga[1394]: bgpd state -&gt; down : read returned EOF</div>
<div>Nov 26 19:30:00 bgpServer watchquagga[1394]: Forked background command [pid 79875]: /usr/local/etc/quagga/service zebra restart</div><div>Nov 26 19:30:01 bgpServer watchquagga[1394]: Forked background command [pid 79879]: /usr/local/etc/quagga/service bgpd start</div>
<div>Nov 26 19:30:01 bgpServer watchquagga[1394]: Phased global restart has completed.</div><div>Nov 26 19:30:01 bgpServer zebra[88251]: SLOW THREAD: task zebra_client_read (102aae0) ran for 24850ms (cpu time 0ms)</div><div>
Nov 26 19:30:01 bgpServer watchquagga[1394]: zebra: slow echo response finally received after 21.684171 seconds</div><div>Nov 26 19:30:01 bgpServer bgpd[79885]: BGPd 0.99.17 starting: vty@2605, bgp@&lt;all&gt;:179</div><div>
Nov 26 19:30:05 bgpServer watchquagga[1394]: bgpd state -&gt; up : connect succeeded</div><div>Nov 26 19:30:06 bgpServer watchquagga[1394]: zebra state -&gt; up : echo response received after 0.065503 seconds</div><div>Nov 26 19:30:21 bgpServer watchquagga[1394]: zebra state -&gt; unresponsive : no response yet to ping sent 10 seconds ago</div>
<div>Nov 26 19:30:35 bgpServer zebra[88251]: SLOW THREAD: task zebra_client_read (102aae0) ran for 24767ms (cpu time 43ms)</div><div>Nov 26 19:30:35 bgpServer watchquagga[1394]: zebra: slow echo response finally received after 24.512305 seconds</div>
<div>Nov 26 19:30:40 bgpServer watchquagga[1394]: zebra state -&gt; up : echo response received after 0.004419 seconds</div><div><br></div><div><br></div><div>Lately i pass 2-3GB of traffic daliy maybe its related? moreover I have 10G Dual card base 82599-EB card connected to a 10GB Switch.</div>
<div><br></div><div>Why these messages arrive? does that mean i have something wrong?</div><div><br></div><div>/etc/sysctl.conf</div><div><div>net.inet.flowtable.enable=0</div><div>net.inet.ip.fastforwarding=1</div><div>kern.ipc.somaxconn=8192</div>
<div>kern.ipc.shmmax=2147483648</div><div>kern.ipc.maxsockets=204800</div><div>kern.ipc.maxsockbuf=262144</div><div>kern.maxfiles=256000</div><div>kern.maxfilesperproc=230400</div><div>net.inet.ip.dummynet.pipe_slot_limit=1000</div>
<div>net.inet.ip.dummynet.io_fast=1</div><div>#10Gb sysctls</div><div>hw.intr_storm_threshold=9000</div><div>kern.ipc.nmbclusters=262144</div><div>kern.ipc.nmbjumbop=262144</div><div>dev.ix.0.rx_processing_limit=4096</div>
<div>dev.ix.1.rx_processing_limit=4096</div></div><div><br></div><div><br></div><div>Thanks in advance,</div><div><br></div>-- <br><div dir="ltr">Sami Halabi<div>Information Systems Engineer</div><div>NMS Projects Expert</div>
</div><br>
</div></div>